Subversion Repositories svn LFS-FR

Rev

Rev 7011 | Blame | Compare with Previous | Last modification | View Log | RSS feed

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
  "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
  <!ENTITY % general-entities SYSTEM "../general.ent">
   %general-entities;
]>
<sect3>
    <title>Choisir la version de programme de Qt</title>
    <para>Si vous installez Qt4 et Qt5, vous pouvez utiliser des scripts simples pour selectionner
    l'ensemble des programmes Qt actuellement actifs. En tant qu'utilisateur
    <systemitem class="username">root</systemitem>, creez les scripts suivants:</para>
<screen role="root">
<userinput>cat &gt; /usr/bin/setqt4 &lt;&lt; 'EOF'
<literal>if [ "x$QT5DIR" != "x/usr" ] &amp;&amp; [ "x$QT5DIR" != "x" ]; then pathremove  $QT5DIR/bin; fi
if [ "x$QT4DIR" != "x/usr" ]; then pathprepend $QT4DIR/bin; fi
echo $PATH</literal>
EOF</userinput>
</screen>
<screen role="root">
<userinput>cat &gt; /usr/bin/setqt5 &lt;&lt; 'EOF'
<literal>if [ "x$QT4DIR" != "x/usr" ] &amp;&amp; [ "x$QT4DIR" != "x" ]; then pathremove  $QT4DIR/bin; fi
if [ "x$QT5DIR" != "x/usr" ]; then pathprepend $QT5DIR/bin; fi
echo $PATH</literal>
EOF</userinput>
</screen>
    <para>Vous pouvez utiliser la version appropriée de Qt en lançant
    <command>source setqt4</command> ou <command>source setqt5</command> comme vous le souhaitez.
    (Initialiser le PATH ne fonctionne pas dans un sous-repertoire.) Une autre technique qui peut
    etre utilisée est de créer des alias appropriés dans votre ~/.bashrc comme
   <command>alias setqt4='source setqt4'</command>.</para>
</sect3>