Subversion Repositories svn LFS-FR

Rev

Rev 7053 | Blame | Compare with Previous | Last modification | View Log | RSS feed

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
  "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
 <!ENTITY % general-entities SYSTEM "../../general.ent">
  %general-entities;
  <!ENTITY libsoup-download-http
          "&gnome-download-http;/libsoup/2.52/libsoup-&libsoup-version;.tar.xz">
  <!ENTITY libsoup-download-ftp
          "&gnome-download-ftp;/libsoup/2.52/libsoup-&libsoup-version;.tar.xz">
  <!ENTITY libsoup-md5sum        "e4757d09012ed93822b1ee41435fec24">
  <!ENTITY libsoup-size          "1.7 Mo">
  <!ENTITY libsoup-buildsize     "45 Mo (avec les tests)">
  <!ENTITY libsoup-time          "0.5 SBU (avec les tests)">
]>
<sect1 id="libsoup" xreflabel="libsoup-&libsoup-version;">
  <?dbhtml filename="libsoup.html"?>
  <sect1info>
    <othername>$LastChangedBy : randy $</othername>
    <date>$Date : 2013-02-11 19:51:17 +0100 (Mon, 11 Feb 2013) $</date>
  </sect1info>
  <title>libsoup-&libsoup-version;</title>
  <indexterm zone="libsoup">
    <primary sortas="a-Libsoup">Libsoup</primary>
  </indexterm>
  <sect2 role="package">
    <title>Introduction à libsoup</title>
    <para>Le paquet <application>libsoup</application> contient une bibliothèque
    client/serveur HTTP pour <application>GNOME</application>. Elle utilise GObject et la boucle principale
    de glib pour s'intégrer aux applications <application>GNOME</application> et elle dispose aussi d'une
    API synchronisée afin d'être utilisable dans des applications threadées.
  </para>
    &lfs78_checked;
    <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
    <itemizedlist spacing='compact'>
      <listitem>
        <para>Téléchargement (HTTP)&nbsp;: <ulink url="&libsoup-download-http;"/></para>
      </listitem>
      <listitem>
        <para>Téléchargement (FTP)&nbsp;: <ulink url="&libsoup-download-ftp;"/></para>
      </listitem>
      <listitem>
        <para>Somme de contrôle MD5 du téléchargement&nbsp;: &libsoup-md5sum;</para>
      </listitem>
      <listitem>
        <para>Taille du téléchargement&nbsp;: &libsoup-size;</para>
      </listitem>
      <listitem>
        <para>Estimation de l'espace disque requis&nbsp;: &libsoup-buildsize;</para>
      </listitem>
      <listitem>
        <para>Estimation du temps de construction&nbsp;: &libsoup-time;</para>
      </listitem>
    </itemizedlist>
    <bridgehead renderas="sect3">Dépendances de libsoup</bridgehead>
    <bridgehead renderas="sect4">Requises</bridgehead>
    <para role="required">
      <xref linkend="glib-networking"/>,
      <xref linkend="libxml2"/> et
      <xref linkend="sqlite"/>
    </para>
     <bridgehead renderas="sect4">Recommandées</bridgehead>
    <para role="recommended">
       <xref linkend="gobject-introspection"/>,
    </para>
    <bridgehead renderas="sect4">Facultatives</bridgehead>
    <para role="optional"><xref linkend="apache"/> (requis pour lancer la suite
    de tests),
      <xref linkend="curl"/> (requis pour lancer la suite de tests),
    <xref linkend="gtk-doc"/>,
     <xref linkend="php"/> compilé avec le support de
      XMLRPC-EPI (utilisé seulement pour les tests de régression XMLRPC) et
      <xref linkend="samba"/> (ntlm_auth est requis pour lancer la suite de test).</para>
    <para condition="html" role="usernotes">Notes utilisateur&nbsp;:
    <ulink url="&blfs-wiki;/libsoup"/></para>
  </sect2>
  <sect2 role="installation">
    <title>Installation de libsoup</title>
    <para>Installez <application>libsoup</application> en lançant les commandes
    suivantes&nbsp;:</para>
<screen>
<userinput>./configure --prefix=/usr --disable-static &amp;&amp;
make</userinput>
</screen>
    <para>Pour tester les résultats, lancez&nbsp;: <command>make check</command>.</para>
    <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem>&nbsp;:</para>
<screen role="root">
<userinput>make install</userinput>
</screen>
  </sect2>
  <sect2 role="commands">
    <title>Explication des commandes</title>
    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
     href="../../xincludes/static-libraries.xml"/>
    <para>
      <option>--disable-vala</option>: utilisez cette option si vous n'avez pas installé
      Vala, si par exemple vous n'avez pas construit gnome.
    </para>



    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
   href="../../xincludes/gtk-doc-rebuild.xml"/>
   </sect2>
  <sect2 role="content">
    <title>Contenu</title>
    <segmentedlist>
      <segtitle>Programmes installés</segtitle>
        <segtitle>Bibliothèques installées</segtitle>
      <segtitle>Répertoires installés</segtitle>
      <seglistitem>
        <seg>Aucun</seg>
        <seg>libsoup-2.4.so et libsoup-gnome-2.4.so</seg>
        <seg>
          /usr/include/libsoup-2.4,
          /usr/include/libsoup-gnome-2.4 et
          /usr/share/gtk-doc/html/libsoup-2.4.
        </seg>
      </seglistitem>
    </segmentedlist>
    <variablelist>
      <bridgehead renderas="sect3">Descriptions courtes</bridgehead>
      <?dbfo list-presentation="list"?>
      <?dbhtml list-presentation="table"?>
      <varlistentry id="libsoup-2">
        <term><filename class="libraryfile">libsoup-2.4.so</filename></term>
        <listitem>
          <para>fournit les fonctions pour des connexions HTTP asynchronisées.</para>
          <indexterm zone="libsoup libsoup-2">
            <primary sortas="c-libsoup-2">libsoup-2.4.so</primary>
          </indexterm>
        </listitem>
      </varlistentry>
      <varlistentry id="libsoup-gnome-2">
        <term><filename class="libraryfile">libsoup-gnome-2.4.so</filename></term>
        <listitem>
          <para>fournit des fonctionnalités spécifiques de <application>Gnome</application>.</para>
          <indexterm zone="libsoup libsoup-gnome-2">
            <primary sortas="c-libsoup-gnome-2">libsoup-gnome-2.4.so</primary>
          </indexterm>
        </listitem>
      </varlistentry>
    </variablelist>
  </sect2>
</sect1>