Subversion Repositories svn LFS-FR

Rev

Blame | Last modification | View Log | RSS feed

<sect2>
<title>Installation de Sed</title>

<para>Lors de l'installation de Sed avec glic-2.1.x à partir de votre système de base,
il peut être nécessaire d'utiliser une correction pour empêcher un conflit de noms de
variables. Les commandes suivantes peuvent être utilisées dans ce cas. Notez que ces
commandes peuvent aussi être utilisées avec d'autres versions de glibc, donc si vous
n'êtes pas sûr, essayez la première version.</para>

<para><screen><userinput>export CPPFLAGS=-Dre_max_failures=re_max_failures2 &amp;&amp;
./configure --prefix=$LFS/usr --bindir=$LFS/bin &amp;&amp;
unset CPPFLAGS &amp;&amp;
make LDFLAGS=-static &amp;&amp;
make install</userinput></screen></para>
 
<para>Si vous utilisez une version plus récente de glibc (2.2.x), vous pouvez utiliser
les commandes suivantes pour installer Sed:</para>
 
<para><screen><userinput>./configure --prefix=$LFS/usr --bindir=$LFS/bin &amp;&amp;
make LDFLAGS=-static &amp;&amp;
make install</userinput></screen></para>

</sect2>