Subversion Repositories svn LFS-FR

Compare Revisions

Ignore whitespace Rev 7017 → Rev 7018

/trunk/blfs/xsoft/other/gimp.xml
72,10 → 72,14
</listitem>
<listitem>
<para>
Correctif facultatif:
<ulink url="&patch-root;/gimp-&gimp-version;-device_info-1.patch"/>
</para>
Estimation de l'espace disque requis&nbsp;: &gimp-help-buildsize;
</para>
</listitem>
<listitem>
<para>
Estimation du temps de construction&nbsp;: &gimp-help-time;
</para>
</listitem>
</itemizedlist>
<bridgehead renderas="sect3">Dépendances de Gimp</bridgehead>
<bridgehead renderas="sect4">Requises</bridgehead>
104,7 → 108,6
<xref linkend="libgudev"/>,
<xref linkend="libmng"/>,
<xref linkend="librsvg"/>,
<ulink url="http://wvware.sourceforge.net/libwmf.html">libwmf</ulink>,
<xref linkend="poppler"/>,
un <xref linkend="server-mail"/> (offrant un programme
<command>sendmail</command>),
122,14 → 125,6
<sect2 role="installation">
<title>Installation de Gimp</title>
<para>
Afin de se débarrasser d'un message gênant lors de l'exécution depuis un terminal
et / ou si vous souhaitez exécuter la suite de tests, utiliser éventuellement la
correctif suivant:
</para>
<screen>
<userinput>patch -Np1 -i ../gimp-&gimp-version;-device_info-1.patch</userinput>
</screen>
<para>
Installez <application>Gimp</application> en lançant
les commandes suivantes&nbsp;:</para>
<screen>
164,6 → 159,56
<xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
href="../../xincludes/update-icons-and-desktop.xml"/>
</sect2>
<sect2 role="installation">
<title>Installation de Gimp-Help</title>
<para>
L'archive <filename>gimp-help</filename> contient des images et des textes d'aide
en anglais pour les fichiers d'aides.
</para>
<para>
Si vous avez téléchargé l'archive <filename>gimp-help</filename>, déballez la
et allez à la base de l'arborescence nouvellement créée. Préparez la construction avec la commande suivante:
</para>
 
<screen><userinput>ALL_LINGUAS=&quot;ca da de el en en_GB es fr it ja ko nl nn pt_BR ru sl sv zh_CN&quot; \
./configure --prefix=/usr &amp;&amp;</userinput></screen>
 
<para>
Supprimez de <envar>ALL_LINGUAS</envar> les codes dans langues que vous ne voulez pas installer. Sinon, supprimez
la ligne démarrant par
<envar>ALL_LINGUAS</envar>, si vous souhaitez construire toutes les langues.
</para>
 
<!-- <para>
Alternatively, if you wish to build languages including Catalan,
apply the patch:
</para>
 
<screen role="nodump"><userinput>xzcat ../gimp-help-2.8.0-build_fixes-1.patch.xz \
| patch -p1 &amp;&amp;
./autogen.sh -prefix=/usr &amp;&amp;</userinput></screen>
 
<para>
Again, you can specify a subset of languages by specifying
<envar>ALL_LINGUAS</envar> in front of <command>./autogen.sh</command>, but
this time including &quot;ca&quot;.
</para>
-->
<para>
Now build the help files:
</para>
 
<screen><userinput>make</userinput></screen>
 
<para>
Tapez les commandes suivantes en tant qu'utilisateurs
<systemitem class="username">root</systemitem> pour installer les fichiers d'aide:
</para>
 
<screen role="root"><userinput>make install &amp;&amp;
chown -R root:root /usr/share/gimp/2.0/help</userinput></screen>
 
</sect2>
<sect2 role="commands" id='gimp-cmd-explanations'>
<title>Explication des commandes</title>
<para>
205,17 → 250,6
<title>Informations de configuration</title>
<para><application>Gimp</application> exécute un assistant de configuration
pour chaque utilisateur lors de leur première utilisation du programme.</para>
<para><application>Gimp</application> exécute le navigateur Internet
<command>firefox</command> par défaut pour afficher les fichiers d'aide.
Si vous n'avez pas <application>firefox</application>, ou si vous préférez
un autre navigateur Internet, vous pouvez régler une autre valeur système
dans <filename>/etc/gimp/2.0/gimprc</filename>. Exécutez la
commande suivante en tant qu'utilisateur <systemitem class="username">root</systemitem>,
en remplaçant <replaceable>&lt;navigateur&gt;</replaceable> par votre
navigateur Internet préféré&nbsp;:</para>
<screen role="root">
<userinput>echo '(web-browser "<replaceable>&lt;browser&gt;</replaceable> %s")' &gt;&gt; /etc/gimp/2.0/gimprc</userinput>
</screen>
</sect3>
</sect2>
<sect2 role="content">
237,13 → 271,10
<seg>
/etc/gimp,
/usr/include/gimp-2.0,
/usr/lib/gimp,
/usr/share/gimp,
/usr/{lib,share}/gimp,
/usr/share/gimp/2.0/help/{en,lang2,lang3,...},
/usr/share/gtk-doc/html/{libgimp,libgimpbase,libgimpcolor},
/usr/share/gtk-doc/html/{libgimpconfig,libgimpmath},
/usr/share/gtk-doc/html/{libgimpmodule,libgimpthumb} et
/usr/share/gtk-doc/html/libgimpwidgets
/usr/share/gtk-doc/html/libgimp{,base,color,config}, et
/usr/share/gtk-doc/html/libgimp{math,module,thumb,widgets}
</seg>
</seglistitem>
</segmentedlist>
/trunk/blfs/xsoft/other/thunderbird.xml
181,12 → 181,6
ac_add_options --with-system-zlib</literal>
EOF</userinput>
</screen>
<para>
Pour commencer, corrigez la construction avec freetype-2.6 ou supérieure:
</para>
<screen>
<userinput>sed -i '/^ftglyph.h/ i ftfntfmt.h' mozilla/config/system-headers</userinput>
</screen>
<para>
Compiler <application>Thunderbird</application> en tapant les commandes suivantes:</para>
<note><para>