Subversion Repositories svn LFS-FR

Compare Revisions

Ignore whitespace Rev 7010 → Rev 7011

/trunk/blfs/xincludes/X11R6_symlink.xml
1,11 → 1,11
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
 
<para>Ce paquet (malheureusement) s'attend à ce que le système <application>X
Window</application> soit installé dans le répertoire
<filename class='directory'>/usr/X11R6</filename>. Si vous utilisez une
version récente de <application>Xorg</application> et qu'elle est
installée à un autre endroit, assurez-vous d'avoir suivi les instructions
installée à un autre endroit, assurez-vous d'avoir suivi les instructions
de la section <xref linkend="X11R6-compat-symlink"/>.</para>
/trunk/blfs/xincludes/gnome-mandir.xml
4,8 → 4,8
<!ENTITY % general-entities SYSTEM "../general.ent">
%general-entities;
]>
 
 
<para><parameter>--mandir=<envar>$GNOME_PREFIX</envar>/share/man</parameter>&nbsp;:
Ce paramètre fait que les fichiers
<filename>man.(X)</filename> s'installent dans
/trunk/blfs/xincludes/gnome-old-prefix.xml
1,7 → 1,7
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<para><parameter>--prefix=$(pkg-config --variable=prefix
ORBit-2.0)</parameter>&nbsp;: Initialisé le préfixe en utilisant ce paramètre au lieu de
<envar>$GNOME_PREFIX</envar> garantira que le prefixe sera cohérent avec l'environnement
/trunk/blfs/xincludes/gnome-old-sysconfdir.xml
4,7 → 4,7
<!ENTITY % general-entities SYSTEM "../general.ent">
%general-entities;
]>
 
<para><parameter>--sysconfdir=<envar>&gnome-old-etc-dir;</envar></parameter>&nbsp;:
Ce paramètre fait que les fichiers de configurations sont installés dans
<filename class="directory">/etc/gnome/2.30.2</filename> au lieu de
/trunk/blfs/xincludes/gnome-prefix.xml
1,7 → 1,7
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<para><parameter>--prefix=<envar>$GNOME_PREFIX</envar></parameter>&nbsp;:
Le réglage du préfixe en utilisant ce paramètre garantira que le préfixe sera
cohérent avec l'environnement d'installation et que le paquet sera
/trunk/blfs/xincludes/gnome-sysconfdir.xml
4,7 → 4,7
<!ENTITY % general-entities SYSTEM "../general.ent">
%general-entities;
]>
 
<para><parameter>--sysconfdir=<envar>$GNOME_SYSCONFDIR</envar></parameter>:
Initialisé sysconfdir en utilisant ce paramètre assurera que sysconfdir
est compatible avec l'environnement d'installation et le paquet que le paquet
/trunk/blfs/xincludes/gnome2.xml
1,7 → 1,7
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<note>
<para>C'est un paquet hérité de <application>GNOME-2</application> qui a été rendu obsolète
par les developpeur de <application>GNOME</application> et qui sera effacé
/trunk/blfs/xincludes/gsettings-destdir.xml
1,7 → 1,7
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<note>
<para>
Si vous installé le paquet dans votre système en utilisant une méthode
/trunk/blfs/xincludes/gtk-doc-rebuild.xml
1,7 → 1,7
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<para><option>--enable-gtk-doc</option>&nbsp;: Utilisez ce paramètre si
<application>GTK-Doc</application> est installé et si vous souhaitez
<application>GTK-Doc</application> est installé et si vous souhaitez
reconstruire et installer la documentation de l'API.</para>
/trunk/blfs/xincludes/gtk-update-icon-cache.xml
1,7 → 1,7
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<note>
<para>
Ce paquet installe des fichiers d'icônes dans la hiérarchie
/trunk/blfs/xincludes/qt-alternatives.xml
1,6 → 1,6
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
<!ENTITY % general-entities SYSTEM "../general.ent">
%general-entities;
]>
8,10 → 8,10
<title>Alternatives d'installation de Qt</title>
<para>L'installation de <application>Qt</application> présente plusieurs challenges et choix.
La complication de l'installation de Qt est le fait qu'il y a deux versions,
<application>Qt4</application> et
<application>Qt4</application> et
<application>Qt5</application>, qui ont des programmes exécutables avec des noms
identiques. Si les deux paquets sont installés sur un système, la seule méthode pour
gérer quel ensemble de programmes est utilisé est soit de contrôler le
gérer quel ensemble de programmes est utilisé est soit de contrôler le
<envar>PATH</envar> de l'utilisateur ou de renommer les fichiers soit directement ou via des
liens symboliques. Les deux paquets ne peuvent pas être installés dans le même répertoire.
</para>
38,14 → 38,14
à une version existante de Qt connue pour fonctionner.
</para>
<para> L'avantage d'installer <application>Qt</application> dans un répertoire personnalisé
comme
<filename class='directory'>/opt/qt-&qt4-version;</filename> ou
<filename class='directory'>/opt/qt-&qt5-version;</filename> ou
comme
<filename class='directory'>/opt/qt-&qt4-version;</filename> ou
<filename class='directory'>/opt/qt-&qt5-version;</filename> ou
est que cela laisse tous les fichiers du paquet consolidés dans une hiérarchie de répertoires
dédiées. En utilisant cette méthode, une mise à jour peut être faite sans écraser une installation
précédente et les utilisateurs peuvent facilement retourner dans une version précédente en
changeant un lien symbolique ou simplement en changeant la variable PATH. Cela permet également
à un développeur de maintenir des versions multiplus de
à un développeur de maintenir des versions multiplus de
<application>Qt4</application>
ou <application>Qt5</application> pour tester. </para>
</sect2>
/trunk/blfs/xincludes/scrollkeeper-dir.xml
1,10 → 1,10
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<para><parameter>--localstatedir=/var/lib</parameter>&nbsp;: Ce paramètre
est utilisé pour que tous les fichiers <application>ScrollKeeper</application>
y soient installés et que les bases de données
y soient installés et que les bases de données
<application>ScrollKeeper</application> soient mises à jour correctement dans
<filename class="directory">/var/lib/scrollkeeper</filename> au lieu que
certains fichiers s'installent dans
/trunk/blfs/xincludes/setqt.xml
1,6 → 1,6
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
<!ENTITY % general-entities SYSTEM "../general.ent">
%general-entities;
]>
26,6 → 26,6
<para>Vous pouvez utiliser la version approprie de Qt en lancant
<command>source setqt4</command> ou <command>source setqt5</command> comme vous le souhaitez.
(Initialisez le PATH ne fonctionne pas dans un sous-repertoire.) Une autre technique qui peut
etre utilisee est de creer des alias appropries dans votre ~/bashrc comme
etre utilisee est de creer des alias appropries dans votre ~/bashrc comme
<command>alias setqt4='source setqt4'</command>.</para>
</sect3>
/trunk/blfs/xincludes/update-desktop-database.xml
1,10 → 1,10
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<note>
<para>
Ce paquet installe des fichiers du bureau dans
Ce paquet installe des fichiers du bureau dans
la hiérarchie <filename class="directory">/usr/share/applications</filename>
et vous pouvez améliorer les performances du système et l'utilisation de la
mémoire en mettant à jour <filename>/usr/share/applications/mimeinfo.cache</filename>.
/trunk/blfs/xincludes/update-icons-and-desktop.xml
1,7 → 1,7
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<note>
<para>
Ce paquet installe des fichiers d'icônes dans la hiérarchie
16,7 → 16,7
<xref linkend="gtk2"/> ou
<xref linkend="gtk3"/> (pour le cache des icônes) et
<xref linkend="desktop-file-utils"/> (pour le cache du bureau) et apez la commande suivante
en tant qu'utilisateur
en tant qu'utilisateur
<systemitem class="username">root</systemitem> :
</para>
<screen role="root">
/trunk/blfs/xincludes/without-gnome.xml
1,7 → 1,7
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE note PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
 
<note>
<para>Les instructions ci-dessous sont basées sur l'installation du paquet
dans un environnement <application>GNOME</application>. Si, pour une raison quelconque, vous installez
8,6 → 8,6
ce paquet sans avoir installé les bibliothèques du c&oelig;ur de
<application>GNOME</application>, vous devrez modifier le paramètre
<option>--prefix=</option> du script <command>configure</command> pour
pointer vers votre chemin d'installation désiré (par exemple,
pointer vers votre chemin d'installation désiré (par exemple,
<option>--prefix=/usr</option>).</para>
</note>