Subversion Repositories svn LFS-FR

Compare Revisions

Ignore whitespace Rev 7020 → Rev 7021

/trunk/blfs/general/genlib/glibmm.xml
64,6 → 64,12
</sect2>
<sect2 role="installation">
<title>Installation de glibmm</title>
<para>
Pour commencer, corrigez le nome du répertoire de documentation:
</para>
<screen><userinput>sed -e '/^libdocdir =/ s/$(book_name)/glibmm-&glibmm-version;/' \
-i docs/Makefile.in</userinput></screen>
 
<para>Installez <application>glibmm</application> en lançant les
commandes suivantes:</para>
<screen>
88,7 → 94,7
libglibmm_generate_extra_defs-2.4.so</seg>
<seg>
/usr/{include,lib}/g{io,lib}mm-2.4 et
/usr/share/{devhelp/books,doc}/glibmm-2.4
/usr/share/{devhelp/books/glibmm-2.4,doc/glibmm-&glibmm-version;}
</seg>
</seglistitem>
</segmentedlist>
/trunk/blfs/general/genlib/qca.xml
54,7 → 54,7
<para role="required">
<xref linkend="cacerts"/>,
<xref linkend="cmake"/>,
<xref linkend="qt4"/> et
<xref linkend="qt4"/> ou <xref linkend="qt5"/>, et
<xref linkend="which"/>
</para>
<bridgehead renderas="sect4">Facultatives</bridgehead>
67,7 → 67,6
<xref linkend="nspr"/>,
<xref linkend="openssl"/>,
<xref linkend="p11-kit"/>,
<xref linkend="qt5"/>,
<xref linkend="doxygen"/>, et
<xref linkend="which"/>
</para>
76,6 → 75,9
</sect2>
<sect2 role="installation">
<title>Installation de Qca</title>
<para>Si vous le souhaitez, supprimez des avertissements énervants à la construction:</para>
<screen><userinput>sed -i 's/BSD/DEFAULT/' CMakeLists.txt</userinput></screen>
 
<para>Installez <application>Qca</application> en lançant les commandes
suivantes&nbsp;:</para>
<screen>
95,7 → 97,7
<para><parameter>-DCMAKE_BUILD_TYPE=Release</parameter>: Ce paramètre est utilisé pour
appliquer le plus haut niveau d'optimisation du compilateur.</para>
<para><parameter>-DQT4_BUILD=ONe</parameter>: Ce paramètre est utilisé pour
forcer la construction avec Qt4 même si Qt5 est trouvé.</para>
forcer la construction avec Qt4 même si Qt5 est trouvé. Il n'y a pas de paquets dans BLFS qui utilisent la version Qt5 de Qca.</para>
<para><parameter>-DQCA_MAN_INSTALL_DIR:PATH=/usr/share/man</parameter>:
Installe les pages de manuel qca à l'emplacement normal.</para>
</sect2>
106,12 → 108,12
<segtitle>Bibliothèques installées</segtitle>
<segtitle>Répertoires installés</segtitle>
<seglistitem>
<seg>mozcerts et qcatool</seg>
<seg>libqca.so et des greffons dans &qt4-dir;/lib/qca/crypto</seg>
<seg>mozcerts et qcatool (si la construction est faite avec Qt5, les binaires ont un suffixe -qt5)</seg>
<seg>libqca.so (libqca-qt5.so pour la constuction avec Qt5) et des greffons dans &qt4-dir;/lib/qca/crypto</seg>
<seg>
&qt4-dir;/include/QtCrypto,
&qt4-dir;/lib/cmake/Qca et
&qt4-dir;/lib/qca
&qt4-dir;/include/QtCrypto (ou &qt5-dir;/include/Qca-qt5),
&qt4-dir;/lib/cmake/Qca (ou &qt5-dir;/lib/cmake/Qca-qt5) and
&qt4-dir;/lib/qca (ou &qt5-dir;/lib/qca-qt5)
</seg>
</seglistitem>
</segmentedlist>
/trunk/blfs/general/prog/lua.xml
78,6 → 78,27
<ulink url="&patch-root;/lua-&lua-version;-shared_library-1.patch"/>
</para>
</listitem>
<listitem>
<para>
Téléchargement de la suite de tests facultatives (HTTP): <ulink url="&lua-tests-download-http;"/>
</para>
</listitem>
<listitem>
<para>
Téléchargement de la suite de tests facultatives (FTP): <ulink url="&lua-tests-download-ftp;"/>
</para>
</listitem>
<listitem>
<para>
somme de contrôle MD5 de la suite de tests facultatives: &lua-tests-md5sum;
</para>
</listitem>
<listitem>
<para>
Taille du téléchargement de la suite de tests facultatives: &lua-tests-size;
</para>
</listitem>
 
</itemizedlist>
<para condition="html" role="usernotes">Notes utilisateur :
<ulink url="&blfs-wiki;/lua"/>
131,6 → 152,13
Cflags: -I${includedir}</literal>
EOF</userinput>
</screen>
<para>
Nous décrivons seulement les "tests basics". Déballez l'archive et allez dans le répertoire
<filename class="directory">lua-&lua-version;-tests</filename>,
ensuite tapez
<command>lua -e"_U=true" all.lua</command>. Si les tests se terminent sans erreur, vous verrez un message contenant "final OK", à la fin.
</para>
 
</sect2>
<sect2 role="commands">
<title>Explication des commandes</title>
153,8 → 181,7
liblua.so
</seg>
<seg>
/usr/lib/lua,
/usr/share/lua et
/usr/{lib,share}/lua et
/usr/share/doc/lua-&lua-version;
</seg>
</seglistitem>
/trunk/blfs/general/prog/perl-modules.xml
127,6 → 127,12
<listitem>
<literallayout>&Archive-Zip-download-http;
Somme MD5: &Archive-Zip-md5sum;</literallayout>
<itemizedlist>
<listitem><literallayout><ulink url="http://search.cpan.org/~gfranks/Test-MockModule/">Test::MockModule</ulink>
(http://search.cpan.org/~gfranks/Test-MockModule/)</literallayout>
</listitem>
</itemizedlist>
 
</listitem>
</itemizedlist>
 
/trunk/blfs/general/prog/php.xml
238,15 → 238,22
<title>Configuration de PHP</title>
<sect3 id="php-config">
<title>Fichiers de configuration</title>
<para><filename>/etc/php.ini</filename>,
<filename>/etc/pear.conf</filename> et
<filename>/etc/php-fpm.conf</filename></para>
<indexterm zone="php php-config">
<para>
<filename>/etc/php.ini</filename>,
<filename>/etc/pear.conf</filename>,
<filename>/etc/php-fpm.conf</filename>, et
<filename>/etc/php-fpm.d/www.conf</filename>
</para>
<indexterm zone="php php-config">
<primary sortas="e-etc-php.ini">/etc/php.ini</primary>
</indexterm>
<indexterm zone="php php-config">
<primary sortas="e-etc-pear.conf">/etc/pear.conf</primary>
</indexterm>
<indexterm zone="php php-config">
<primary sortas="e-etc-php-fpm.d-www.conf">
/etc/php-fpm.d/www.conf</primary>
</indexterm>
<indexterm zone="php php-config">
<primary sortas="e-etc-php-fpm.conf">/etc/php-fpm.conf</primary>
</indexterm>
253,6 → 260,18
</sect3>
<sect3>
<title>Informations de configuration</title>
<para>
Sans le fichier <filename>/etc/php-fpm.d/www.conf</filename>,
le gestionnaire de processus ne démarre pas. Cependant, c'est le fichier
<filename>/etc/php-fpm.d/www.conf.default</filename>, qui est installé. Pour résoudre cela, tapez
en tant qu'utilisateur
<systemitem class="username">root</systemitem> :
</para>
<screen role="root"><userinput>cp -v /etc/php-fpm.d/www.conf.default /etc/php-fpm.d/www.conf</userinput></screen>
 
 
 
 
<para>Le fichier utilisé en tant que fichier de configuration
<filename>/etc/php.ini</filename> par défaut est recommandé par l'équipe
de développement de <application>PHP</application>. Ce fichier modifie le
320,11 → 339,11
<segtitle>Bibliothèques installées</segtitle>
<segtitle>Répertoires installés</segtitle>
<seglistitem>
<seg>pear, peardev, pecl, phar (lien symbolique), phar.phar,
php, php-cgi, php-config, php-fpm, et phpize</seg>
<seg>pear, peardev, pecl, phar (symlink), phar.phar, php,
php-cgi, php-config, php-fpm, phpdbg, et phpize</seg>
<seg>dba.{so,a} et opcache.{so,a} dans
/usr/lib/php/extensions/no-debug-non-zts-20131226/</seg>
<seg>/usr/{include,lib,share}/php et
/usr/lib/php/extensions/no-debug-non-zts-20151012</seg>
<seg>/etc/php-fpm.d, /usr/{include,lib,share}/php et
/usr/share/doc/php-&php-version;</seg>
</seglistitem>
</segmentedlist>
362,6 → 381,19
</indexterm>
</listitem>
</varlistentry>
<varlistentry id="phpdbg">
<term><command>phpdbg</command></term>
<listitem>
<para>
est le debogueur intéractif de PHP.
</para>
<indexterm zone="php phpdbg">
<primary sortas="b-phpdbg">phpdbg</primary>
</indexterm>
</listitem>
</varlistentry>
 
 
</variablelist>
</sect2>
</sect1>
/trunk/blfs/general/sysutils/dbus.xml
341,10 → 341,12
libdbus-1.so
</seg>
<seg>
/{etc,/usr/share}/dbus-1,
/etc/dbus-1,
/usr/{include,lib}/dbus-1.0,
/usr/share/doc/dbus-&dbus-version; et
/var/{lib,run}/dbus </seg>
/usr/share/dbus-1,
/usr/share/doc/dbus-&dbus-version;, et
/var/{lib,run}/dbus
</seg>
</seglistitem>
</segmentedlist>
<variablelist>
/trunk/blfs/networking/connect/dhcpcd.xml
200,7 → 200,7
<seglistitem>
<seg>dhcpcd</seg>
<seg>/lib/dhcpcd/dev/udev.so</seg>
<seg>/lib/dhcpcd</seg>
<seg>/{,/var}/lib/dhcpcd</seg>
</seglistitem>
</segmentedlist>
<variablelist>
/trunk/blfs/networking/netlibs/curl.xml
65,7 → 65,10
<xref linkend="samba"/>,
<ulink url="http://daniel.haxx.se/projects/c-ares/">c-ares</ulink>,
<ulink url="https://launchpad.net/libmetalink/">libmetalink</ulink>,
<ulink url="http://www.libssh2.org">libssh2</ulink>, et
<ulink url="https://github.com/rockdaboot/libpsl">Libpsl</ulink>,
<ulink url="http://www.libssh2.org">libssh2</ulink>,
<ulink url="https://tls.mbed.org/">mbed TLS (formellement connue sous
PolarSSL)</ulink>, et
<ulink url="http://spnego.sourceforge.net/">
SPNEGO</ulink>
</para>
/trunk/blfs/networking/netlibs/libtirpc.xml
48,15 → 48,6
<para>Estimation du temps de construction&nbsp;: &libtirpc-time;</para>
</listitem>
</itemizedlist>
<bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
<itemizedlist spacing="compact">
<listitem>
<para>
Correctif requis:
<ulink url="&patch-root;/libtirpc-&libtirpc-version;-api_fixes-1.patch"/>
</para>
</listitem>
</itemizedlist>
<bridgehead renderas="sect3">Dépendances de libtirpc</bridgehead>
<bridgehead renderas="sect4">Facultatives</bridgehead>
<para role="optional">
67,12 → 58,10
</sect2>
<sect2 role="installation">
<title>Installation de libtirpc</title>
<para>
Pour commencer, corrigez quelques problèmes d' API:
</para>
<screen>
<userinput>patch -Np1 -i ../libtirpc-0.3.2-api_fixes-1.patch</userinput>
</screen>
<note>
<para>
A la mise à jour de ce paquet, vous devez également mettre à jour toutes les versions existantes de <xref linkend='rpcbind'/></para></note>
 
<para>Installez <application>libtirpc</application> en lançant les commandes
suivantes&nbsp;:</para>
<screen>
/trunk/blfs/networking/netprogs/rpcbind.xml
51,6 → 51,15
<para>Estimation du temps de construction&nbsp;: &rpcbind-time;</para>
</listitem>
</itemizedlist>
<bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
<itemizedlist spacing="compact">
<listitem>
<para>
Correctif requis:
<ulink url="&patch-root;/rpcbind-&rpcbind-version;-tirpc_fix-1.patch"/>
</para>
</listitem>
</itemizedlist>
<bridgehead renderas="sect3">Dépendances de rpcbind</bridgehead>
<bridgehead renderas="sect4">Requises</bridgehead>
<para role="required">
/trunk/blfs/networking/netprogs/samba.xml
152,6 → 152,10
</sect2>
<sect2 role="commands">
<title>Explication des commandes</title>
 
<para><command>sed ... -i ./lib/async_req/wscript_build</command>: N'installe pas async_connect_send_test.</para>
 
 
<para><parameter>--enable-fhs</parameter>&nbsp;: Affecte tous les autres
chemins de fichiers de façon conforme au <foreignphrase>Filesystem Hierarchy
Standard</foreignphrase> (standard de hiérarchie de système de fichiers) (FHS).</para>
/trunk/blfs/postlfs/security/gnupg2.xml
70,6 → 70,7
<xref linkend="libusb-compat"/>,
un <xref linkend="server-mail"/>,
<xref linkend="openldap"/> ,
<xref linkend="sqlite"/>,
<xref linkend="texlive"/> (oo <xref linkend="tl-installer"/>), et
<ulink url="http://www.chiark.greenend.org.uk/~ian/adns/">GNU
adns</ulink>
146,6 → 147,8
class="directory">/usr/share/doc/gnupg-&gnupg2-version;</filename>.</para>
<para><parameter>--enable-symcryptrun</parameter>&nbsp;: Ce paramètre autorise la
construction du programme symcryptrun.</para>
<para><option>--enable-g13</option>: Ce paramètre active la construction du programme
g13.</para>
 
</sect2>
<sect2 role="content">
212,7 → 215,7
<varlistentry id="g13">
<term><command>g13</command></term>
<listitem>
<para>est un outil pour créer, monter ou démonter un container de système de fichiers chiffré.
<para>est un outil pour créer, monter ou démonter un container de système de fichiers chiffré (facultatif).
</para>
<indexterm zone="gnupg2 g13">
<primary sortas="b-g13">g13</primary>
/trunk/blfs/postlfs/security/openssl.xml
70,7 → 70,7
<userinput>./config --prefix=/usr --openssldir=/etc/ssl --libdir=lib shared zlib-dynamic &amp;&amp;
make</userinput>
</screen>
<para>Pour tester les résultats, lancez&nbsp;: <command>make -j1 test</command>.</para>
<para>Pour tester les résultats, lancez&nbsp;: <command>make test</command>.</para>
<para>
Si vous voulez désactiver l'installation des bibliothèques statiques, utilisez la commande sed&nbsp;:
</para>
/trunk/blfs/pst/printing/cups.xml
350,8 → 350,10
libcupsppdc.so et libcups.so
</seg>
<seg>
/{etc,usr/{include,lib,share},var/{cache,log,run,spool}}/cups and
/usr/share/doc/cups-&cups-version;
/etc/cups,
/usr/{include,lib,share}/cups,
/usr/share/doc/cups-&cups-version;, et
/var/{cache,log,run,spool}/cups
</seg>
</seglistitem>
</segmentedlist>
/trunk/blfs/server/databases/lmdb.xml
79,7 → 79,7
<sect2 role="installation">
<title>Installation de lmdb</title>
 
<note><para>Ce paquet est extrait de lmdb-LMDB_0.9.16.</para></note>
<note><para>Ce paquet est extrait de lmdb-LMDB_&lmdb-version;</para></note>
 
<para>
Installez <application>lmdb</application> en lançant les commandes suivantes :
102,6 → 102,17
<screen role="root"><userinput>make prefix=/usr install</userinput></screen>
 
</sect2>
<sect2 role="commands">
<title>Explications des commandes</title>
<para>
<command>sed ... prefix ... Makefile</command>: Le Makefile crée le repertoire des pages de man pendant l'installation s'il n'est pas présent.
Cette correction corrige l'emplacement du répertoire.
</para>
<para>
<command>sed ... liblmdb.a ... Makefile</command>: Les exécutables du paquet utilise une bibliothèque statique qui doit être créée. Cette commande supprime la création
de cette bibliothèque statique.
</para>
</sect2>
 
<sect2 role="content">
<title>Contenu</title>
/trunk/blfs/server/other/openldap.xml
321,7 → 321,8
et plusieurs sous /usr/lib/openldap
</seg>
<seg>
/{etc,{usr,var}/lib}/openldap et
/etc/openldap,
/{usr,var}/lib/openldap, et
/usr/share/doc/openldap-&openldap-version;
</seg>
</seglistitem>
/trunk/blfs/traduc/commits/r16709.txt
File deleted
/trunk/blfs/traduc/commits/r16708.txt
File deleted
/trunk/blfs/traduc/commits/r16707.txt
File deleted
/trunk/blfs/traduc/commits/r16706.txt
File deleted
/trunk/blfs/traduc/commits/r16705.txt
File deleted
/trunk/blfs/traduc/commits/r16704.txt
File deleted
/trunk/blfs/traduc/commits/r16703.txt
File deleted
/trunk/blfs/traduc/commits/r16702.txt
File deleted
/trunk/blfs/traduc/commits/r16701.txt
File deleted
/trunk/blfs/traduc/commits/r16700.txt
File deleted
/trunk/blfs/traduc/commits/r16699.txt
File deleted
/trunk/blfs/traduc/commits/r16698.txt
File deleted
/trunk/blfs/traduc/commits/r16697.txt
File deleted
/trunk/blfs/traduc/commits/r16696.txt
File deleted
/trunk/blfs/traduc/commits/r16695.txt
File deleted
/trunk/blfs/traduc/commits/r16694.txt
File deleted
/trunk/blfs/x/lib/atkmm.xml
55,6 → 55,12
</sect2>
<sect2 role="installation">
<title>Installation de atkmm</title>
<para>
Pour commencer, corrigez le nom du répertoire de documentation:
</para>
<screen><userinput>sed -e '/^libdocdir =/ s/$(book_name)/atkmm-&atkmm-version;/' \
-i doc/Makefile.in</userinput></screen>
 
<para>Installez <application>atkmm</application> en lançant les commandes suivantes&nbsp;:
</para>
<screen>
77,10 → 83,8
<seg>Aucun</seg>
<seg>libatkmm-1.6.so</seg>
<seg>
/usr/include/atkmm-1.6,
/usr/lib/atkmm-1.6,
/usr/share/devhelp/books/atkmm-1.6 and
/usr/share/doc/atkmm-1.6
/usr/{include,lib}/atkmm-1.6 et
/usr/share/{devhelp/books/atkmm-1.6,doc/atkmm-&atkmm-version;}
</seg>
</seglistitem>
</segmentedlist>
/trunk/blfs/x/lib/cairomm.xml
57,6 → 57,12
</sect2>
<sect2 role="installation">
<title>Installation de cairomm</title>
<para>
Pour commencer, corrigez le nom du répertoire de documentation:
</para>
<screen><userinput>sed -e '/^libdocdir =/ s/$(book_name)/cairomm-&cairomm-version;/' \
-i docs/Makefile.in</userinput></screen>
 
<para>Installer <application>cairomm</application> en exécutant les commandes
suivantes:</para>
<screen>
79,11 → 85,9
<seg>Aucun</seg>
<seg>libcairomm-1.0.so</seg>
<seg>
/usr/include/cairomm-1.0,
/usr/lib/cairomm-1.0,
/usr/share/devhelp/books/cairomm-1.0 et
/usr/share/doc/cairomm-1.0
</seg>
/usr/{include,lib}/cairomm-1.0 et
/usr/share/{devhelp/books/cairomm-1.0,doc/cairomm-&cairomm-version;}
</seg>
</seglistitem>
</segmentedlist>
<variablelist>
/trunk/blfs/x/lib/gtk+3.xml
118,14 → 118,12
Si vous souhaitez lacer la suite de tests, créez (ou mettez à jour) le fichier en utilisant
la commande suivante en tant qu'utilisateur
<systemitem class="username">root</systemitem> :
<command>glib-compile-schemas /usr/share/glib-2.0/schemas</command>.
</para>
<screen role="root">
<userinput>glib-compile-schemas /usr/share/glib-2.0/schemas</userinput>
</screen>
<para>
Si le test <filename>flipping-icons.ui</filename> échoue, supprimez le:
Si le test <filename>flipping-icons.ui</filename> échoue, supprimez le avec
<command>rm -v testsuite/reftests/flipping-icons.ui</command>.
</para>
<screen><userinput>rm -v testsuite/reftests/flipping-icons.ui</userinput></screen>
<para>
Pour tester les résultats vous avez besoin d'une session graphique, ensuite tapez
<command>make check</command>.</para>
/trunk/blfs/x/lib/gtkmm2.xml
75,6 → 75,11
</sect2>
<sect2 role="installation">
<title>Installation de Gtkmm</title>
<para>
Pour commencer, corrigez le nom du répertoire de documentation:
</para>
<screen><userinput>sed -e '/^libdocdir =/ s/$(book_name)/gtkmm-&gtkmm2-version;/' \
-i docs/Makefile.in</userinput></screen>
<para>
Installez <application>Gtkmm</application> en lançant les commandes
commands:
117,9 → 122,8
/usr/include/gdkmm-2.4,
/usr/include/gtkmm-2.4,
/usr/lib/gdkmm-2.4,
/usr/lib/gtkmm-2.4,
/usr/share/devhelp/books/gtkmm-2.4 et
/usr/share/doc/gtkmm-2.4.
/usr/lib/gtkmm-2.4, et
/usr/share/{devhelp/books/gtkmm-2.4,doc/gtkmm-&gtkmm2-version;}
</seg>
</seglistitem>
</segmentedlist>
/trunk/blfs/x/lib/gtkmm3.xml
57,6 → 57,12
</sect2>
<sect2 role="installation">
<title>Installation de gtkmm</title>
<para>
Pour commencer, corrigez le nom du répertoire de documentation:
</para>
<screen><userinput>sed -e '/^libdocdir =/ s/$(book_name)/gtkmm-&gtkmm3-version;/' \
-i docs/Makefile.in</userinput></screen>
 
<para>Installer <application>gtkmm</application> en exécutant les commandes
suivantes:</para>
<screen>
84,9 → 90,8
/usr/include/gdkmm-3.0,
/usr/include/gtkmm-3.0,
/usr/lib/gdkmm-3.0,
/usr/lib/gtkmm-3.0,
/usr/share/devhelp/books/gtkmm-3.0 et
/usr/share/doc/gtkmm-3.0.
/usr/lib/gtkmm-3.0, et
/usr/share/{devhelp/books/gtkmm-3.0,doc/gtkmm-&gtkmm3-version;}
</seg>
</seglistitem>
</segmentedlist>
/trunk/blfs/x/lib/pangomm.xml
56,6 → 56,12
</sect2>
<sect2 role="installation">
<title>Installation de pangomm</title>
<para>
Pour commencer, corriger le nom du répertoire de documentation:
</para>
<screen><userinput>sed -e '/^libdocdir =/ s/$(book_name)/pangomm-&pangomm-version;/' \
-i docs/Makefile.in</userinput></screen>
 
<para>Installez <application>pangomm</application> en lançant les commandes
suivantes:</para>
<screen>
79,9 → 85,8
<seg>libpangomm-1.4.so</seg>
<seg>
/usr/include/pangomm-1.4,
/usr/lib/pangomm-1.4,
/usr/share/devhelp/books/pangomm-1.4 et
/usr/share/doc/pangomm-1.4
/usr/lib/pangomm-1.4, et
/usr/share/{devhelp/books/pangomm-1.4,doc/pangomm-&pangomm-version;}
</seg>
</seglistitem>
</segmentedlist>