Subversion Repositories svn LFS-FR

Compare Revisions

Ignore whitespace Rev 466 → Rev 467

/trunk/blfs/xsoft/graphweb/dillo.xml
1,6 → 1,6
<sect1 id="dillo" xreflabel="dillo-&dillo-version;">
<sect1 id="dillo" xreflabel="Dillo-&dillo-version;">
<?dbhtml filename="dillo.html" dir="xsoft"?>
<title>dillo-&dillo-version;</title>
<title>Dillo-&dillo-version;</title>
 
&dillo-intro;
&dillo-inst;
/trunk/blfs/xsoft/graphweb/dillo/dillo-config.xml
1,5 → 1,5
<sect2>
<title>Configurer <application>dillo</application></title>
<title>Configurer <application>Dillo</application></title>
 
<sect3><title>Fichiers de configuration</title>
<para>Une configuration système est possible en utilisant
11,12 → 11,12
<para><application>Dillo</application> enregistre sa configuration pour chaque
utilisateur dans des fichiers disponible sous <filename
class="directory">~/.dillo</filename>. Ces fichiers sont créés automatiquement
au lancement de <command>dillo</command>. Par défaut, les cookies ne sont pas
activés par <application>dillo</application>. Pour les activer, éditez le
au lancement de <command>Dillo</command>. Par défaut, les cookies ne sont pas
activés par <application>Dillo</application>. Pour les activer, éditez le
fichier <filename>~/.dillo/cookiesrc</filename>. Le fichier
<filename>~/.dillo/bookmarks.html</filename> est créé par
<application>dillo</application>. Il peut aussi être modifié avec n'importe quel
éditeur texte ou html.</para>
<application>Dillo</application>. Il peut aussi être modifié avec n'importe quel
éditeur texte ou <acronym>HTML</acronym>.</para>
</sect3>
 
</sect2>
/trunk/blfs/xsoft/graphweb/dillo/dillo.ent
1,12 → 1,11
<!ENTITY dillo SYSTEM "../dillo.xml">
<!ENTITY dillo-intro SYSTEM "dillo-intro.xml">
<!ENTITY dillo-inst SYSTEM "dillo-inst.xml">
<!ENTITY dillo-exp SYSTEM "dillo-exp.xml">
<!ENTITY dillo-config SYSTEM "dillo-config.xml">
<!ENTITY dillo-desc SYSTEM "dillo-desc.xml">
<!ENTITY dillo-config SYSTEM "dillo-config.xml">
<!ENTITY dillo-buildsize "14,2 Mo">
<!ENTITY dillo-version "0.7.3">
<!ENTITY dillo-download-http "http://www.dillo.org/download/dillo-&dillo-version;.tar.bz2">
<!ENTITY dillo-download-ftp "">
<!ENTITY dillo-size "345 Ko">
<!ENTITY dillo-buildsize "14,2 Mo">
<!ENTITY dillo-time "0,23 SBU">
/trunk/blfs/xsoft/graphweb/dillo/dillo-intro.xml
1,11 → 1,11
<sect2>
<title>Introduction à dillo</title>
<title>Introduction à Dillo</title>
 
<para><application>Dillo</application> est un navigateur web graphique rapide et
peu consomnateur en mémoire. Bien que la version &dillo-version; est en phase
alpha, il est stable. <application>Dillo</application> ne supporte pas
<application>java</application> ou javascript, et la version actuelle ne
supporte pas le copier/cooler, le ftp, https ou les cadres. Il est néanmoins
supporte pas le copier/cooler, le <acronym>FTP</acronym>, https ou les cadres. Il est néanmoins
très rapide et donc utile sur les anciennes machines, assez lentes. Il supporte
les téléchargements et peut autoriser les cookies.</para>
 
22,7 → 22,7
&dillo-time;</para></listitem></itemizedlist>
</sect3>
 
<sect3><title>Dépendances de <application>dillo</application></title>
<sect3><title>Dépendances de <application>Dillo</application></title>
<sect4><title>Requis</title>
<para><xref linkend="GTK"/></para></sect4>
</sect3>
/trunk/blfs/xsoft/graphweb/dillo/dillo-inst.xml
1,7 → 1,12
<sect2>
<title>Installation de <application>dillo</application></title>
<title>Installation de <application>Dillo</application></title>
 
<para>Installez <application>dillo</application> en lançant les commandes
<note><para>Dillo ne dispose pas de mécanisme de sélection d'ensemble de
caractères et utilise en permanence iso8859-1. Si celui-ci n'est pas approprié,
remplacez toutes les occurences de iso8859-1 par celui que vous souhaitez dans
<filename>src/dw_style.c</filename>.</para></note>
 
<para>Installez <application>Dillo</application> en lançant les commandes
suivantes:</para>
 
<screen><userinput><command>./configure --prefix=/usr --sysconfdir=/etc &amp;&amp;
/trunk/blfs/xsoft/graphweb/dillo/dillo-desc.xml
1,7 → 1,7
<sect2>
<title>Contenu</title>
 
<para>Le package <application>dillo</application> contient
<para>Le package <application>Dillo</application> contient
<command>dillo</command>.</para>
 
</sect2>
10,8 → 10,9
 
<sect3><title>dillo</title>
<para><command>dillo</command> est un navigateur <acronym>WWW</acronym>
graphique basé sur gtk+, disposant de possibilités limitées mais ayant une
petite empreinte mémoire et très rapide sur des machines lentes.</para></sect3>
graphique basé sur <acronym>GTK</acronym>+, disposant de possibilités limitées
mais ayant une petite empreinte mémoire et très rapide sur des machines lentes.
</para></sect3>
 
</sect2>
 
/trunk/blfs/xsoft/graphweb/galeon.xml
1,6 → 1,6
<sect1 id="galeon" xreflabel="galeon-&galeon-version;">
<sect1 id="galeon" xreflabel="Galeon-&galeon-version;">
<?dbhtml filename="galeon.html" dir="xsoft"?>
<title>galeon-&galeon-version;</title>
<title>Galeon-&galeon-version;</title>
 
&galeon-intro;
&galeon-inst;
/trunk/blfs/xsoft/graphweb/galeon/galeon-inst.xml
1,11 → 1,11
<sect2>
<title>Installation de <application>galeon</application></title>
<title>Installation de <application>Galeon</application></title>
 
<para>La compilation doit être faite avec la même version de compilateur et les
mêmes optimisations que celles utilisées pour <application>mozilla</application>.
mêmes optimisations que celles utilisées pour <application>Mozilla</application>.
</para>
 
<para>Installez <application>galeon</application> en lançant les commandes suivantes:
<para>Installez <application>Galeon</application> en lançant les commandes suivantes:
</para>
 
<screen><userinput><command>./configure --prefix=$GNOME_PREFIX --sysconfdir=/etc/gnome \
/trunk/blfs/xsoft/graphweb/galeon/galeon-desc.xml
1,7 → 1,7
<sect2>
<title>Contenu</title>
 
<para>Le package <application>galeon</application> contient <command>galeon</command>
<para>Le package <application>Galeon</application> contient <command>galeon</command>
et <command>galeon-config-tool</command>.</para>
 
</sect2>
15,7 → 15,8
 
<sect3><title>galeon-config-tool</title>
<para><command>galeon-config-tool</command> efface les paramétrages, installe les
schémas, supprime des schémas et corrige les permissions dans gconf.</para></sect3>
schémas, supprime des schémas et corrige les permissions dans
<application>GConf</application>.</para></sect3>
 
</sect2>
 
/trunk/blfs/xsoft/graphweb/galeon/galeon-config.xml
1,11 → 1,7
<sect2>
<title>Configurer galeon</title>
<title>Configurer <application>Galeon</application></title>
 
<para>Ajoutez au profil système ou personnel:</para>
 
<para><screen>export MOZILLA_FIVE_HOME=/opt/mozilla/lib/mozilla</screen></para>
 
<para>Si root peut exécuter galeon, mais qu'un utilisateur ne le peut pas,
<para>Si root peut exécuter <command>galeon</command>, mais qu'un utilisateur ne le peut pas,
cet utilisateur doit exécuter cette commande à partir de son répertoire
principal:</para>
 
/trunk/blfs/xsoft/graphweb/galeon/galeon.ent
1,12 → 1,10
<!ENTITY galeon SYSTEM "../galeon.xml">
<!ENTITY galeon-intro SYSTEM "galeon-intro.xml">
<!ENTITY galeon-inst SYSTEM "galeon-inst.xml">
<!ENTITY galeon-exp SYSTEM "galeon-exp.xml">
<!ENTITY galeon-desc SYSTEM "galeon-desc.xml">
<!ENTITY galeon-config SYSTEM "galeon-config.xml">
<!ENTITY galeon-buildsize "122,3 Mo">
<!ENTITY galeon-version "1.3.7">
<!ENTITY galeon-download-http "http://telia.dl.sourceforge.net/sourceforge/galeon/galeon-1.3.7.tar.gz">
<!ENTITY galeon-version "1.3.10">
<!ENTITY galeon-download-http "http://telia.dl.sourceforge.net/sourceforge/galeon/galeon-&galeon-version;.tar.gz">
<!ENTITY galeon-download-ftp "">
<!ENTITY galeon-size "2,9 Mo">
<!ENTITY galeon-buildsize "122,3 Mo">
<!ENTITY galeon-time "1,95 SBU">
/trunk/blfs/xsoft/graphweb/galeon/galeon-intro.xml
1,8 → 1,8
<sect2>
<title>Introduction à <application>galeon</application></title>
<title>Introduction à <application>Galeon</application></title>
 
<para>Le package <application>galeon</application> contient le navigateur GNOME
utilisant le moteur de rendu gecko de <application>mozilla</application> et
<para>Le package <application>Galeon</application> contient le navigateur GNOME
utilisant le moteur de rendu gecko de <application>Mozilla</application> et
présentant l'interface la plus simple possible pour un navigateur.</para>
 
<sect3><title>Informations sur le package</title>
18,7 → 18,7
&galeon-time;</para></listitem></itemizedlist>
</sect3>
 
<sect3><title>Dépendances de <application>galeon</application></title>
<sect3><title>Dépendances de <application>Galeon</application></title>
<sect4><title>Requis</title>
<para><xref linkend="libgnomeui"/>, <xref linkend="scrollkeeper"/> et
<xref linkend="mozilla"/></para></sect4>
/trunk/blfs/xsoft/graphweb/galeon/galeon-exp.xml
1,13 → 1,14
<sect2>
<title>Explications des commandes</title>
 
<para><command>--sysconfdir=/etc/gnome</command> : Cette commande place les
fichiers de configuration dans <filename>/etc/gnome</filename> au lieu de
<filename>$GNOME_PREFIX/etc</filename>.</para>
<para><parameter>--sysconfdir=/etc/gnome</parameter> : Cette commande place les
fichiers de configuration dans <filename class="directory">/etc/gnome</filename>
au lieu de <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
<para><command>--localstatedir=/var/lib</command> : Cette commande place les
fichiers scrollkeeper dans <filename>/var/lib/scrollkeeper</filename> au lieu de
<filename>$GNOME_PREFIX/var/scrollkeeper</filename>.<para>
<para><parameter>--localstatedir=/var/lib</parameter> : Cette commande place les
fichiers <application>ScrollKeeper</application> dans <filename
class="directory">/var/lib/scrollkeeper</filename> au lieu de
<filename class="directory">$GNOME_PREFIX/var/scrollkeeper</filename>.<para>
 
</sect2>
 
/trunk/blfs/xsoft/graphweb/mozilla.xml
1,10 → 1,11
<sect1 id="mozilla" xreflabel="mozilla-&mozilla-version;">
<sect1 id="mozilla" xreflabel="Mozilla-&mozilla-version;">
<?dbhtml filename="mozilla.html" dir="xsoft"?>
<title>mozilla-&mozilla-version;</title>
<title>Mozilla-&mozilla-version;</title>
 
&mozilla-intro;
&mozilla-inst;
&mozilla-exp;
&mozilla-config;
&mozilla-desc;
 
</sect1>
/trunk/blfs/xsoft/graphweb/konq.xml
1,9 → 1,9
<sect1 id="konq" xreflabel="konq">
<sect1 id="konq" xreflabel="Konqueror-&kde-version;">
<?dbhtml filename="konq.html" dir="xsoft"?>
<title>konqueror-&kde-version;</title>
<title>Konqueror-&kde-version;</title>
 
<para>Konqueror est le navigateur web graphique par défaut pour l'environnement
de bureau KDE. Il est fourni et installé avec <xref linkend="kde-base"/>.</para>
<para>Konqueror est le navigateur web par défaut pour l'environnement de burau
KDE. Il est installé avec <xref linkend="kde-base"/>.</para>
 
</sect1>
 
/trunk/blfs/xsoft/graphweb/mozilla/mozilla-intro.xml
1,53 → 1,62
<sect2>
<title>Introduction à mozilla</title>
<title>Introduction à <application>Mozilla</application></title>
 
<screen>
Site de téléchargement (HTTP): <ulink url="&mozilla-download-http;"/>
Site de téléchargement (FTP): <ulink url="&mozilla-download-ftp;"/>
Version utilisée: &mozilla-version;
Taille du package: &mozilla-size;
Estimation de l'espace disque requis: &mozilla-buildsize;
Estimation du temps de construction: &mozilla-buildtime;
Estimation de l'espace requis pour l'installation: &mozilla-installsize;</screen>
<para><application>Mozilla</application> est une suite de navigation, la
contre-partie Open Source de <application>Netscape</application>. Elle inclut le
navigateur, un client mail, un client pour les calendriers et un client
<acronym>IRC</acronym>.</para>
 
<para>Mozilla est une suite navigateur, le côté opensource de Netscape. Il
inclut un navigateur, un composeur, un client mail et un client IRC. Un
composan calendrier peut aussi être construit mais il n'est pas encore
intégré dans la version stable de mozilla.</para>
<para>Le projet Mozilla gère aussi deux sous-projets qui ont pour ambition de
contenter les besoins des utilisateursqui n'ont pas besoin de la suite complète
ou qui apprécient d'avoir des applications séparées pour naviguer ou pour leurs
courriers. Ces sous-projets sont
<ulink url="http://www.mozilla.org/products/firebird/">Mozilla Firebird</ulink>,
(un navigateur indépendant basé sur le code source de Mozilla) et
<ulink url="http://www.mozilla.org/projects/thunderbird/">Mozilla Thunderbird</ulink>,
(un client mail indépendant basé sur le code source de Mozilla). Les
instructions de construction pour ces deux applications séparées sont abordées
dans cette section au lieu d'avoir une section séparée car les instructions
d'installation sont très similaires à celles de
<application>Mozilla</application>. De plus, à cause de cette similarité, seules
les modifications requises en respect des instructions
pour <application>Mozilla</application> sont mentionnées.</para>
 
<screen>mozilla dépend de
<xref linkend="freetype2"/>, <xref linkend="xfree86"/>, <xref linkend="zip"/>,
<xref linkend="expat"/>, <xref linkend="ATK"/>, <xref linkend="Pango"/>,
<xref linkend="pkgconfig"/>, <!-- <xref linkend="fontconfig">, -->
<xref linkend="GLib2"/>, <xref linkend="GTK2"/>, <xref linkend="libIDL"/>,
<xref linkend="lcms"/>, <xref linkend="libjpeg"/>, <xref linkend="libmng"/>,
<xref linkend="libpng"/> et <xref linkend="which"/></screen>
<sect3><title>Informations sur le package</title>
<itemizedlist spacing='compact'>
<listitem><para>Téléchargement (HTTP): <ulink
url="&mozilla-download-http;"/></para></listitem>
<listitem><para>Téléchargement (FTP): <ulink
url="&mozilla-download-ftp;"/></para></listitem>
<listitem><para>Taille du téléchargement: &mozilla-size;</para></listitem>
<listitem><para>Estimation de l'espace disque requis:
&mozilla-buildsize;</para></listitem>
<listitem><para>Estimation du temps de construction:
&mozilla-time;</para></listitem></itemizedlist>
</sect3>
 
<para>Téléchargez le correctif de différents problèmes pour la construction de
<userinput><ulink url="&hfile-root;"/></userinput>. Les correctifs commencent
avec <userinput>mozilla-&mozilla-version;</userinput>. Notez qu'aucun des
correctifs n'est obligatoire, ils sont tous optionnels. Référez-vous aux notes
en haut du fichier correctif pour savoir si vous en avez besoin.</para>
<sect3><title>Dépendances de <application>Mozilla</application></title>
<sect4><title>Requis</title>
<para><xref linkend="freetype2"/>, <xref linkend="xfree86"/>, <xref
linkend="zip"/>, <xref linkend="expat"/>, <xref linkend="ATK"/>, <xref
linkend="Pango"/>, <xref linkend="pkgconfig"/>, <!-- <xref
linkend="fontconfig">, --> <xref linkend="GLib2"/>, <xref linkend="GTK2"/>,
<xref linkend="libIDL"/>, <xref linkend="lcms"/>, <xref linkend="libjpeg"/>,
<xref linkend="libmng"/>, <xref linkend="libpng"/> et <xref linkend="which"/>
</para></sect4>
<sect4><title>Recommendé</title>
<para><xref linkend="gnupg"/> (pour l'extension Enigmail)
</para></sect4>
</sect3>
 
<para>Notez que les instructions pour le vérificateur orthographique de mozdev
ont été supprimé car l'API du vérificateur a été modifié et est actuellement
cassé.</para>
<!--
<para>Télécharger le correcteur orthographique (un projet Mozdev).
<screen><ulink url="&hfile-root;/mozilla-&mozilla-version;-spellchecker.tar.bz2"/></screen>
</para>
-->
<sect3><title>Téléchargements supplémentaires</title>
<itemizedlist spacing='compact'>
<listitem><para><ulink url="http://enigmail.mozdev.org/">Enigmail Extension</ulink>
(Utile seulement si Mozilla Mail est construit): <ulink
url="http://downloads.mozdev.org/enigmail/src/enigmail-&enigmail-version;.tar.gz"/></para></listitem>
<listitem><para><ulink url="http://enigmail.mozdev.org/">Inter Process Communicaton Extension</ulink>
(Nécessaire pour Enigmail): <ulink
url="http://downloads.mozdev.org/enigmail/src/ipc-&ipc-version;.tar.gz"/></para></listitem>
</itemizedlist>
</sect3>
 
<para>Si vous avez des difficultés lors de la construction de mozilla, vérifiez
sur l'astuce mozilla (<ulink url="http://www.linuxfromscratch.org/~tushar/"/>)
pour des informations détaillées. Les instructions qui suivent installent la
suite complète. Pour sélectionner des composants spécifiques, référez-vous à
l'astuce.
<!--
Also if you are looking to install some exotic extensions,
check <ulink url="http://www.linuxfromscratch.org/~tushar/build-scripts"/>
if there are any instructions.
-->
</para>
 
</sect2>
/trunk/blfs/xsoft/graphweb/mozilla/mozilla-exp.xml
1,78 → 1,82
<sect2>
<title>Explications des commandes</title>
 
<para><userinput>export MOZILLA_OFFICIAL="1" &amp;&amp;
export BUILD_OFFICIAL="1" &amp;&amp;
export MOZ_INTERNAL_LIBART_LGPL="1"</userinput>
<para><screen><command>export MOZILLA_OFFICIAL="1" &amp;&amp;
export BUILD_OFFICIAL="1"</command></screen>
Mets en place quelques variables qui affecte ce qui sera construit et comment.
Les deux premiers exports spécifient que nous allons construire une
distribution. Le dernier export indique que nous sommes d'accord pour libart
en version LGPL.</para>
en version <acronym>LGPL</acronym>.</para>
 
<para><userinput>--prefix=&mozilla-prefix;</userinput>: Auparavant, mozilla ne
<para><parameter>--prefix=/usr</parameter>: Auparavant, mozilla ne
supportait pas l'option make install. Donc, le package était installé dans
<filename>/opt</filename>. Le package supporte maintenant "make install" et suit
les lignes de conduite du FHS pour l'installation. Le livre recommande donc
maintenant l'installation avec un préfixe système tel que
les lignes de conduite du <acronym>FHS</acronym> pour l'installation. Le livre
recommande donc maintenant l'installation avec un préfixe système tel que
<filename>/usr</filename>.</para>
 
<para><screen><userinput>--enable-toolkit-gtk2</userinput></screen> : Utilise
<para><screen><option>--enable-toolkit-gtk2</option></screen> : Utilise
la boîte à outils gtk2.</para>
 
<para><screen><userinput>--with-system-zlib --with-system-jpeg \
--with-system-png --with-system-mng"</userinput></screen>
<para><screen><option>--with-system-zlib --with-system-jpeg \
--with-system-png --with-system-mng"</option></screen>
Utilisez les versions du système pour ces packages.</para>
 
<para><userinput>--enable-xft</userinput>: Active le support de Xft. Vous avez
besoin de fontconfig ou de la dernière version de XFree86 pour activer xft.
<para><option>--enable-xft</option>: Active le support de Xft. Vous avez
besoin de <application>FontConfig</application> ou de la dernière version de
<application>XFree86</application> pour activer xft.
</para>
 
<para><userinput>--enable-crypto</userinput>: Active le Gestionnaire de Sécurité
Personnel pour permettre les connexions SSL.</para>
<para><option>--enable-crypto</option>: Active le Gestionnaire de Sécurité
Personnel pour permettre les connexions <acronym>SSL</acronym>.</para>
 
<para><screen><userinput>--disable-jsd --disable-accessibility \
<para><screen><option>--disable-jsd --disable-accessibility \
--disable-tests --disable-debug \
--disable-dtd-debug \
--disable-logging --enable-reorder \
--enable-strip \
--enable-cpp-rtti</userinput></screen>
--enable-cpp-rtti</option></screen>
Différentes options indiquant quels composants seront construit et d'autres
options d'optimisations. Vous pouvez choisir ces options. Plus d'informations
sur elles peut être trouvé dans l'aide du script de configuration de mozilla.
sur elles peut être trouvé dans l'aide du script de configuration de
<application>Mozilla</application>.
Toutes les options ne sont pas utilisées dans les instructions données
ci-dessus.</para>
 
<para><userinput>--enable-extensions=...</userinput>: Active les extensions.
Si vou sle souhaitez, vous pouvez désactiver toutes les extensions autre que
Si vous le souhaitez, vous pouvez désactiver toutes les extensions autre que
le navigateur en changeant cette option par
<userinput>--enable-extensions="default,-venkman,-inspector,-irc"</userinput>.</para>
<parameter>--enable-extensions="default,-venkman,-inspector,-irc"</parameter>.</para>
 
<para><userinput>--enable-svg</userinput>: Active le support de SVG (Scalable
Vector Graphics).</para>
 
<para><screen><userinput>install -d &mozilla-prefix;/include/mozilla-&mozilla-version;/security
cp -Lf dist/private/security/*.h dist/public/security/*.h \
&mozilla-prefix;/include/mozilla-&mozilla-version;/security</userinput></screen>
<para><screen><command>install -d /usr/include/mozilla-&mozilla-version;/nss
cp -Lf dist/private/nss/*.h dist/public/nss/*.h \
/usr/include/mozilla-&mozilla-version;/nss</command></screen>
Copie les entêtes nss qui ne sont pas copiés par make install.</para>
 
<!--
<para><userinput>install -d &mozilla-prefix;/lib/mozilla-&mozilla-version;/openoffice</userinput>:
<para><userinput>install -d /usr/lib/mozilla-&mozilla-version;/openoffice</userinput>:
Crée un répertoire pour stocker les bibliothèques statiques dont openoffice a
besoin lors de la compilation. Ces bibliothèques ne sont pas installées par
défaut.</para>
-->
 
<para><userinput>ln -nsf mozilla-&mozilla-version; ...</userinput>:
Mozilla installe les entêtes et bibliothèques dans des répertoires spécifiques
à la version. Ce lien crée des liens symboliques pour que les applications
dépendant de Mozilla (comme OpenOffice, Galeon, etc...) puissent utiliser
un chemin non spécifique à la version lors de l'installation.</para>
<para><command>ln -nsf mozilla-&mozilla-version; ...</command>:
<application>Mozilla</application> installe les entêtes et bibliothèques dans
des répertoires spécifiques à la version. Ce lien crée des liens symboliques
pour que les applications dépendant de <application>Mozilla</application> (comme
<application>OpenOffice</application>, <application>Galeon</application>, etc...)
puissent utiliser un chemin non spécifique à la version lors de l'installation.
</para>
 
<para><screen><userinput>export LD_LIBRARY_PATH="&mozilla-prefix;/lib/mozilla-&mozilla-version;" &amp;&amp;
export MOZILLA_FIVE_HOME="&mozilla-prefix;/lib/mozilla-&mozilla-version;" &amp;&amp;
<para><screen><command>export LD_LIBRARY_PATH="/usr/lib/mozilla-&mozilla-version;" &amp;&amp;
export MOZILLA_FIVE_HOME="/usr/lib/mozilla-&mozilla-version;" &amp;&amp;
./regxpcom &amp;&amp;
./regchrome &amp;&amp;
touch `find &mozilla-prefix;/lib/mozilla-${VERSION} -name *.rdf`</userinput></screen>
touch `find /usr/lib/mozilla-${VERSION} -name *.rdf`</command>
</screen>
Crée les registeres composants requis pour activer l'installation multiple.
</para>
 
/trunk/blfs/xsoft/graphweb/mozilla/mozilla-inst.xml
1,26 → 1,12
<sect2>
<title>Installation de mozilla</title>
<title>Installation de <application>Mozilla</application></title>
 
<para>Installez mozilla en lançant les commandes suivantes:</para>
 
<para><screen><userinput>export MOZILLA_OFFICIAL="1" &amp;&amp;
export BUILD_OFFICIAL="1" &amp;&amp;
export MOZ_INTERNAL_LIBART_LGPL="1" &amp;&amp;
<!--
cd extensions &amp;&amp;
rm -rf spellcheck &amp;&amp;
tar -xjf ../../mozilla-&mozilla-version;-spellchecker.tar.bz2 &amp;&amp;
cd .. &amp;&amp;
-->
for p in ../mozilla-&mozilla-version;-*.patch
do patch -Np1 -i $p
done</userinput></screen></para>
 
<note>
<para>D'après les institutions financières, le correctif suivant rend votre
navigateur non sécurisé. Vous avez été prévenu. Un grand nombre de sites utilise
un indicatif MS-IE spécifique (autocomplete=off) pour empêcher la complétion
automatique de fonctionner dans certaines formes. Cet indicatif est maintenant
supporté par mozilla pour faire plaisir aux institutions financières. Quant aux
supporté par <application>Mozilla</application> pour faire plaisir aux institutions financières. Quant aux
nécessités des institutions financières, ils n'accepteront même pas une solution
où ceci est une préférence, une option. Néanmoins, notre opinion est que ceci
est l'affaire de l'utilisateur. Pour activer la complétion automatique et passer
28,12 → 14,21
code.</para>
 
<para>Ouvrez le fichier <filename>extensions/wallet/src/wallet.cpp</filename>
à partir des sources mozilla et recherchez la ligne:
à partir des sources <application>Mozilla</application> et recherchez la ligne:
<screen>#define WALLET_DONT_CACHE_ALL_PASSWORDS</screen>
Alors supprimez ou mettez cette ligne en commentaire. Maintenant, si quelqu'un
vous dit que MS-IE est facile d'utilisation, donnez cet exemple!</para>
</note>
 
<para><screen><userinput>./configure --prefix=&mozilla-prefix; \
<para>Si vous pensez installer Enigmail, récupérez les archives tar d'ipc et
d'engimail dans le répertoire <filename class="directory">extensions</filename>.</para>
 
<para>Compilez <application>Mozilla</application> en lançant les commandes
suivantes:</para>
 
<screen><userinput><command>export MOZILLA_OFFICIAL="1" &amp;&amp;
export BUILD_OFFICIAL="1" &amp;&amp;
./configure --prefix=/usr \
--enable-default-mozilla-five-home \
--enable-toolkit-gtk2 --enable-default-toolkit=gtk2 \
--with-x --with-system-zlib \
43,27 → 38,46
--disable-accessibility \
--disable-tests --disable-debug \
--disable-logging --enable-reorder \
--enable-strip \
--enable-cpp-rtti --enable-extensions=all \
--enable-svg &amp;&amp;
--enable-strip --disable-pedantic \
--enable-cpp-rtti --enable-extensions=all &amp;&amp;
make</command></userinput></screen>
 
<para>Si vous installez Enigmail, exécutez les étapes suivantes:</para>
 
<screen><userinput><command>cd extensions/ipc &amp;&amp;
./makemake -r &amp;&amp;
make &amp;&amp;
make install &amp;&amp;
install -d &mozilla-prefix;/include/mozilla-&mozilla-version;/nss &amp;&amp;
cd ../enigmail &amp;&amp;
./makemake -r &amp;&amp;
make &amp;&amp;
cd ../..</command></userinput></screen>
 
<para>Installez <application>Mozilla</application> de cette façon:</para>
 
<screen><userinput><command>make install &amp;&amp;
install -d /usr/include/mozilla-&mozilla-version;/nss &amp;&amp;
cp -Lf dist/private/nss/*.h dist/public/nss/*.h \
&mozilla-prefix;/include/mozilla-&mozilla-version;/security &amp;&amp;
<!--
install -d &mozilla-prefix;/lib/mozilla-&mozilla-version;/openoffice &amp;&amp;
cp -f dist/lib/libembed_base_s.a dist/lib/liblber50.a \
dist/lib/libmozreg_s.a &mozilla-prefix;/lib/mozilla-&mozilla-version;/openoffice &amp;&amp;
-->
ln -nsf mozilla-&mozilla-version; &mozilla-prefix;/include/mozilla &amp;&amp;
ln -nsf mozilla-&mozilla-version; &mozilla-prefix;/lib/mozilla &amp;&amp;
cd &mozilla-prefix;/lib/mozilla-&mozilla-version; &amp;&amp;
export LD_LIBRARY_PATH="&mozilla-prefix;/lib/mozilla-&mozilla-version;" &amp;&amp;
export MOZILLA_FIVE_HOME="&mozilla-prefix;/lib/mozilla-&mozilla-version;" &amp;&amp;
/usr/include/mozilla-&mozilla-version;/nss &amp;&amp;
ln -nsf mozilla-&mozilla-version; /usr/include/mozilla &amp;&amp;
ln -nsf mozilla-&mozilla-version; /usr/lib/mozilla</command></userinput></screen>
 
<para>Installez Enigmail de cette façon:</para>
 
<screen><userinput><command>for i in components/enigmime.xpt \
components/ipc.xpt components/libenigmime.so components/enigmail.js \
components/enigmail.xpt chrome/enigmail.jar
do
install dist/bin/$i /usr/lib/mozilla-&mozilla-version;/$i
done</command></userinput></screen>
 
<para>Pour activer les opérations multi-utilisateurs, exécutez ce qui suit:</para>
 
<screen><userinput><command>cd /usr/lib/mozilla-&mozilla-version; &amp;&amp;
export LD_LIBRARY_PATH="/usr/lib/mozilla-&mozilla-version;" &amp;&amp;
export MOZILLA_FIVE_HOME="/usr/lib/mozilla-&mozilla-version;" &amp;&amp;
./regxpcom &amp;&amp;
./regchrome &amp;&amp;
touch `find &mozilla-prefix;/lib/mozilla-&mozilla-version; -name *.rdf`</userinput></screen></para>
touch `find /usr/lib/mozilla-&mozilla-version; -name *.rdf`</command></userinput></screen>
 
</sect2>
 
71,24 → 85,69
<title>Options supplémentaires</title>
 
<para>Chacune de ses options peut être ajoutée à la ligne de configure pour
avoir l'effet décrit sur la compilation de mozilla.</para>
avoir l'effet décrit sur la compilation de <application>Mozilla</application>.</para>
 
<para><userinput>--disable-mailnews</userinput> : Désactive les clients mail et
news.</para>
<para><option>--enable-elf-dynstr-gc</option>: Supprime les chaînes non
référencées à partir d'objets partagés <acronym>ELF</acronym> générés lors de la
construction. Notez que cette option casse la construction sur les machines à
base de processeur alpha.</para>
 
<para><userinput>--disable-ldap</userinput> : Désactive le support de LDAP,
recommandé si le mail a été désactivé.</para>
<para><option>--disable-mailnews</option>: Désactive les clients mail et news.
</para>
 
<para><userinput>--enable-calendar</userinput> : Construit le client pour le
calendrier. Vous aurez besoin de télécharger les sources du calendrier via cvs
car il n'est pas inclus avec les sources de cette version. (Attention, cette
option n'est pas encore stable).</para>
<para><option>--disable-ldap</option>: Désactive le support de
<acronym>LDAP</acronym>, ce qui est recommendé si le mail est désactivé.
</para>
 
<para><userinput>--enable-xterm-updates</userinput> : Cette option active le
titre du xterm avec la commande courante lors de la compilation.</para>
<para><option>--enable-calendar</option>: Construit le client pour le calendrier.</para>
 
<para><userinput>--enable-plaintext-editor-only</userinput> : Désactive le
support pour l'édition HTML. N'utilisez pas cette option si vous souhaitez
construire le composant mail-news.</para>
<para><option>--enable-xterm-updates</option>: Cette option est nécessaire pour
activer le titre <command>xterm</command> avec la commande actuelle lors de la
compilation.</para>
 
<para><option>--enable-plaintext-editor-only</option>: Désactive le support de
l'édition <acronym>HTML</acronym>. N'utilisez pas cette option si vous
construisez le composant mail-news.</para>
 
</sect2>
 
<sect2>
<title>Notes de construction supplémentaires pour <application>Mozilla Firebird</application> &firebird-version;</title>
 
<para>Ajoutez la variable d'environnement suivante (la variable est nommé
Phoenix car il s'agissait de l'ancien nom du projet <application>Mozilla
Firebird</application>):</para>
 
<screen><userinput><command>export MOZ_PHOENIX="1"</command></userinput></screen>
 
<para>Assurez-vous que les options suivantes sont passées à
<command>./configure</command>: <option>--disable-calendar</option> et
<option>--disable-mailnews</option>.</para>
 
<para>Nous recommendons l'installation dans un répertoire séparé tel que
<parameter>--prefix=/opt/firebird-&firebird-version;</parameter> pour
prévenir les problèmes avec un <application>Mozilla</application> installé.</para>
 
<para>L'exécutable <application>Mozilla Firebird</application> est
<command>MozillaFirebird</command>.</para>
 
</sect2>
 
<sect2>
<title>Notes de construction supplémentaires pour <application>Mozilla Thunderbird</application> &thunderbird-version;</title>
 
<para>Ajoutez la variable d'environnement suivante:</para>
 
<screen><userinput><command>export MOZ_THUNDERBIRD="1"</command></userinput></screen>
 
<para>Assurez-vous que les options suivantes sont passées à
<command>./configure</command>: <option>--disable-calendar</option>.</para>
 
<para>Nous recommendons l'installation dans un répertoire séparé tel que
<parameter>--prefix=/opt/thunderbird-&thunderbird-version;</parameter>
pour prévenir les problèmes avec un <application>Mozilla</application> installé.</para>
 
<para>L'exécutable <application>Mozilla Thunderbird</application> est
<command>thunderbird</command>.</para>
 
</sect2>
/trunk/blfs/xsoft/graphweb/mozilla/mozilla-desc.xml
1,9 → 1,10
<sect2>
<title>Contenu</title>
 
<para>Le package mozilla contient <userinput>mozilla</userinput>. Les nombreux
composants comme le composeur, le client mail sont accessibles dans le menu
après le démarrage de mozilla ou via des options sur la ligne de commande du
binaire mozilla.</para>
<para>Le package <application>Mozilla</application> contient
<command>mozilla</command>. Les nombreux composants comme le composeur, le
client mail sont accessibles dans le menu après le démarrage de
<command>mozilla</command> ou via des options sur la ligne de commande du
binaire <command>mozilla</command>.</para>
 
</sect2>
/trunk/blfs/xsoft/graphweb/mozilla/mozilla-config.xml
1,19 → 1,23
<sect2>
<title>Configurer mozilla</title>
<title>Configurer Mozilla</title>
 
<para>Aucune configuration spécifique n'est requise tant que le binaire mozilla
se trouve dans le path de l'utilisateur. Si vous avez installé mozilla à un
emplacement non-standard tel que &mozilla-prefix;, alors créez un lien
symbolique vers le binaire mozilla à partir de /usr/bin.</para>
<para>Aucune configuration spécifique n'est requise tant que le binaire
<command>mozilla</command> se trouve dans le path de l'utilisateur. Si
<application>Mozilla</application> est installé dans un répertoire non standard,
alors créez un lien symbolique vers le binaire <command>mozilla</command> à
partir du répertoire <filename class="directory">/usr/bin</filename>. Ceci
s'applique aussi à <application>Mozilla FireBird</application> et à
<application>Mozilla Thunderbird</application>.</para>
 
<para>Beaucoup d'applications recherchent netscape lorsqu'elles ont besoin
d'ouvrir un navigateur. Vous pouvez créer un lien symbolique pour plus de
facilité.</para>
<para>Beaucoup d'applications recherchent <command>netscape</command>
lorsqu'elles ont besoin d'ouvrir un navigateur. Vous pouvez créer un lien
symbolique pour plus de facilité.</para>
 
<para><screen><userinput>ln -sf mozilla &mozilla-prefix;/bin/netscape</userinput></screen></para>
<screen><userinput><command>ln -sf mozilla &mozilla-prefix;/bin/netscape</command></userinput></screen>
 
<para>Pour installer les plugins variés de mozilla, référez-vous à l'URL
mentionnée précédement pour l'astuce mozilla.</para>
<para>Pour installer les plugins variés de <application>Mozilla</application>,
référez-vous au <ulink url="http://plugindoc.mozdev.org/linux.html">projet
PluginDoc de Mozdev</ulink>.</para>
 
</sect2>
 
/trunk/blfs/xsoft/graphweb/mozilla/mozilla.ent
2,14 → 2,15
<!ENTITY mozilla-intro SYSTEM "mozilla-intro.xml">
<!ENTITY mozilla-inst SYSTEM "mozilla-inst.xml">
<!ENTITY mozilla-exp SYSTEM "mozilla-exp.xml">
<!ENTITY mozilla-config SYSTEM "mozilla-config.xml">
<!ENTITY mozilla-desc SYSTEM "mozilla-desc.xml">
<!ENTITY mozilla-config SYSTEM "mozilla-config.xml">
<!ENTITY mozilla-buildsize "550 Mo">
<!ENTITY mozilla-version "1.4">
<!ENTITY mozilla-prefix "/usr">
<!ENTITY mozilla-version "1.5">
<!ENTITY firebird-version "0.7">
<!ENTITY thunderbird-version "0.3">
<!ENTITY enigmail-version "0.76.7">
<!ENTITY ipc-version "1.0.4">
<!ENTITY mozilla-download-http "http://ftp.mozilla.org/pub/mozilla/releases/mozilla&mozilla-version;/src/mozilla-source-&mozilla-version;.tar.bz2">
<!ENTITY mozilla-download-ftp "ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla&mozilla-version;/src/mozilla-source-&mozilla-version;.tar.bz2">
<!ENTITY mozilla-download-ftp "ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla&mozilla-version;/src/mozilla-source-&mozilla-version;.tar.bz2">
<!ENTITY mozilla-size "39 Mo">
<!ENTITY mozilla-buildtime "2 heures (850 MHz)">
<!ENTITY mozilla-installsize "65 Mo">
<!ENTITY mozilla-time "79,04 SBU">
<!ENTITY mozilla-buildsize "550 Mo">
<!ENTITY mozilla-time "22,64 SBU">
/trunk/blfs/xsoft/graphweb/graphweb.xml
2,6 → 2,10
<?dbhtml filename="graphweb.html" dir="xsoft"?>
<title>Navigateurs Web Graphiques</title>
 
<para>Ce chapitre contient une sélection magnifique de navigateurs. Nous
espérons que vous y trouverez celui que vous appréciez ou les testerez tous.
</para>
 
&mozilla;
&galeon;
&xsoft-graphweb-konq;
/trunk/blfs/xsoft/other/other.xml
2,6 → 2,8
<?dbhtml filename="other.html" dir="xsoft"?>
<title>Autres Programmes Internet basés sur X</title>
 
<para>L'Internet n'est pas uniquement un navigateur. Voici quelques applications
graphiques qui utilisent d'autres aires de l'Internet.</para>
 
&pan;
&balsa;
/trunk/blfs/xsoft/other/balsa.xml
1,4 → 1,4
<sect1 id="balsa" xreflabel="balsa-&balsa-version;">
<sect1 id="balsa" xreflabel="Balsa-&balsa-version;">
<?dbhtml filename="balsa.html" dir="xsoft"?>
<title>Balsa-&balsa-version;</title>
 
/trunk/blfs/xsoft/other/balsa/balsa-config.xml
1,11 → 1,12
<sect2>
<title>Configurer Balsa</title>
<title>Configurer <application>Balsa</application></title>
 
 
<sect3><title>Informations de configuration</title>
 
<para>Toute la configuration de Balsa est faite avec le menu système Balsa, et
la configuration de la boîte mail avec le menu Settings-&gt;Preferences.</para>
<para>Toute la configuration de <application>Balsa</application> est faite avec
le menu système <application>Balsa</application>, et la configuration de la
boîte mail avec le menu Settings-&gt;Preferences.</para>
</sect3>
 
</sect2>
/trunk/blfs/xsoft/other/balsa/balsa.ent
2,11 → 2,11
<!ENTITY balsa-intro SYSTEM "balsa-intro.xml">
<!ENTITY balsa-inst SYSTEM "balsa-inst.xml">
<!ENTITY balsa-exp SYSTEM "balsa-exp.xml">
<!ENTITY balsa-config SYSTEM "balsa-config.xml">
<!ENTITY balsa-desc SYSTEM "balsa-desc.xml">
<!ENTITY balsa-config SYSTEM "balsa-config.xml">
<!ENTITY balsa-buildsize "74 Mo">
<!ENTITY balsa-version "2.0.14">
<!ENTITY balsa-download-http "http://balsa.gnome.org/balsa-&balsa-version;.tar.bz2">
<!ENTITY balsa-download-ftp "">
<!ENTITY balsa-size "2,7 Mo">
<!ENTITY balsa-buildsize "74 Mo">
<!ENTITY balsa-time "0,82">
/trunk/blfs/xsoft/other/balsa/balsa-intro.xml
2,7 → 2,7
<title>Introduction à <application>Balsa</application></title>
 
<para>Le package <application>Balsa</application> contient un lecteur de mail
basé sur GNOME 2.</para>
basé sur <application><acronym>GNOME</acronym></application> 2.</para>
 
<sect3><title>Informations sur le package</title>
<itemizedlist spacing='compact'>
/trunk/blfs/xsoft/other/balsa/balsa-exp.xml
1,21 → 1,22
<sect2>
<title>Explication des commandes</title>
 
<para><command>--localstatedir=/var/lib</command> : Cette option place les
fichiers de scrollkeeper dans <filename>/var/lib/scrollkeeper</filename> au lieu
de <filename>$GNOME_PREFIX/var/scrollkeeper</filename>.</para>
<para><parameter>--localstatedir=/var/lib</parameter> : Cette option place les
fichiers de <application>ScrollKeeper</application> dans <filename
class="directory">/var/lib/scrollkeeper</filename> au lieu
de <filename class="directory">$GNOME_PREFIX/var/scrollkeeper</filename>.</para>
 
<para><command>--with-ssl</command> : Modifie la configuration de Balsa qui
<para><option>--with-ssl</option> : Modifie la configuration de Balsa qui
ne propose pas par défaut le support de SSL.</para>
 
<para><command>--sysconfdir=/etc/gnome</command> : Cette option place les
fichiers de configuration dans <filename>/etc/gnome</filename> au lieu de
<filename>$GNOME_PREFIX/etc</filename>.</para>
<para><parameter>--sysconfdir=/etc/gnome</parameter> : Cette option place les
fichiers de configuration dans <filename class="directory">/etc/gnome</filename> au lieu de
<filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
<para><command>--with-ldap</command> : Change la valeur par défaut pour
<para><option>--with-ldap</option> : Change la valeur par défaut pour
activer le support de <acronym>LDAP</acronym> s'il est disponible.</para>
 
<para><command>--with-gpgme</command> : Change la valeur par défaut pour
<para><option>--with-gpgme</option> : Change la valeur par défaut pour
activer le support de <acronym>GPG</acronym> si 'GnuPG made easy'
(<acronym>GPGME</acronym>) est installé.</para>
 
/trunk/blfs/xsoft/other/balsa/balsa-desc.xml
1,7 → 1,8
<sect2>
<title>Contenu</title>
 
<para>Le package Balsa contient <userinput>balsa</userinput>.</para>
<para>Le package <application>Balsa</application> contient
<command>balsa</command>.</para>
 
</sect2>
 
8,7 → 9,7
<sect2><title>Description</title>
 
<sect3><title>balsa</title>
<para>Balsa est le lecteur mail basé sur Gnome 2.</para></sect3>
<para><command>balsa</command> est le lecteur mail basé sur <application><acronym>GNOME</acronym></application> 2.</para></sect3>
 
</sect2>
 
/trunk/blfs/xsoft/other/pan.xml
1,6 → 1,6
<sect1 id="pan" xreflabel="pan-&pan-version;">
<sect1 id="pan" xreflabel="Pan-&pan-version;">
<?dbhtml filename="pan.html" dir="xsoft"?>
<title>pan-&pan-version;</title>
<title>Pan-&pan-version;</title>
 
&pan-intro;
&pan-inst;
/trunk/blfs/xsoft/other/pan/pan.ent
1,12 → 1,10
<!ENTITY pan SYSTEM "../pan.xml">
<!ENTITY pan-intro SYSTEM "pan-intro.xml">
<!ENTITY pan-inst SYSTEM "pan-inst.xml">
<!ENTITY pan-exp SYSTEM "pan-exp.xml">
<!ENTITY pan-desc SYSTEM "pan-desc.xml">
<!ENTITY pan-config SYSTEM "pan-config.xml">
<!ENTITY pan-buildsize "67,8 Mo">
<!ENTITY pan-version "0.14.2">
<!ENTITY pan-download-http "http://pan.rebelbase.com/download/releases/&pan-version;/SOURCE/pan-&pan-version;.tar.bz2">
<!ENTITY pan-download-ftp "">
<!ENTITY pan-size "1,8 Mo">
<!ENTITY pan-buildsize "67,8 Mo">
<!ENTITY pan-time "0,72 SBU">
/trunk/blfs/xsoft/other/pan/pan-intro.xml
1,7 → 1,7
<sect2>
<title>Introduction à pan</title>
<title>Introduction à <application>Pan</application></title>
 
<para>Le package pan contient un lecteur de news graphique. C'est utile pour
<para>Le package <application>Pan</application> contient un lecteur de news graphique. C'est utile pour
lire et écrire des news, hiérarchiser des articles et y répondre via email.
</para>
 
18,7 → 18,7
&pan-time;</para></listitem></itemizedlist>
</sect3>
 
<sect3><title>Dépendances de <application>pan</application></title>
<sect3><title>Dépendances de <application>Pan</application></title>
<sect4><title>Requis</title>
<para><xref linkend="GTK2"/>, <xref linkend="gnet"/>, <xref
linkend="intltool"/> et <xref linkend="libxml2"/></para></sect4>
/trunk/blfs/xsoft/other/pan/pan-inst.xml
1,7 → 1,7
<sect2>
<title>Installation de <application>pan</application></title>
<title>Installation de <application>Pan</application></title>
 
<para>Installez <application>pan</application> en lançant les commandes
<para>Installez <application>Pan</application> en lançant les commandes
suivantes:</para>
 
<screen><userinput><command>./configure --prefix=/usr &amp;&amp;
/trunk/blfs/xsoft/other/pan/pan-desc.xml
1,7 → 1,7
<sect2>
<title>Contenu</title>
 
<para>Le package <application>pan</application> contient <command>pan</command>.
<para>Le package <application>Pan</application> contient <command>pan</command>.
</para>
 
</sect2>
/trunk/blfs/xsoft/office/evolution.xml
1,10 → 1,7
<sect1 id="evolution" xreflabel="evolution-&evolution-version;">
<sect1 id="evolution" xreflabel="Evolution-&evolution-version;">
<?dbhtml filename="evolution.html" dir="xsoft"?>
<title>evolution-&evolution-version;</title>
<title>Evolution-&evolution-version;</title>
 
&db-3.1-intro;
&db-3.1-inst;
&db-3.1-exp;
&evolution-intro;
&evolution-inst;
&evolution-exp;
/trunk/blfs/xsoft/office/evolution/evolution-desc.xml
1,8 → 1,13
<sect2>
<title>Contenu</title>
 
<para>Le package evolution contient la suite Evolution, email, calendrier et
carnet d'adresse.</para>
<para>Le package <application>Evolution</application> contient la suite
Evolution, email, calendrier et carnet d'adresse.</para>
 
<sect2><title>Description</title>
<sect3><title>evolution</title>
<para><command>evolution</command> contient une suite avec client mail, gestion
de calendriers et carnet d'adresses.</para></sect3>
 
</sect2>
 
/trunk/blfs/xsoft/office/evolution/evolution.ent
3,19 → 3,9
<!ENTITY evolution-inst SYSTEM "evolution-inst.xml">
<!ENTITY evolution-exp SYSTEM "evolution-exp.xml">
<!ENTITY evolution-desc SYSTEM "evolution-desc.xml">
<!ENTITY evolution-config SYSTEM "evolution-config.xml">
<!ENTITY evolution-version "1.4.4">
<!ENTITY evolution-download-http "http://ftp.gnome.org/pub/GNOME/sources/evolution/1.4/evolution-&evolution-version;.tar.bz2">
<!ENTITY evolution-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/evolution/1.4/evolution-&evolution-version;.tar.bz2">
<!ENTITY evolution-size "12 Mo">
<!ENTITY evolution-buildsize "387 Mo">
<!ENTITY evolution-version "1.2.1">
<!ENTITY evolution-download-http "http://ftp.gnome.org/pub/GNOME/sources/evolution/1.2/evolution-&evolution-version;.tar.bz2">
<!ENTITY evolution-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/evolution/1.2/evolution-&evolution-version;.tar.bz2">
<!ENTITY evolution-size "12 Mo">
 
<!ENTITY db-3.1 SYSTEM "../db-3.1.xml">
<!ENTITY db-3.1-intro SYSTEM "db-3.1-intro.xml">
<!ENTITY db-3.1-inst SYSTEM "db-3.1-inst.xml">
<!ENTITY db-3.1-exp SYSTEM "db-3.1-exp.xml">
<!ENTITY db-3.1-buildsize "18 Mo">
<!ENTITY db-3.1-version "3.1.17">
<!ENTITY db-3.1-download-http "http://www.sleepycat.com/update/snapshot/db-3.1.17.tar.gz">
<!ENTITY db-3.1-download-ftp "">
<!ENTITY db-3.1-size "2 Mo">
<!ENTITY evolution-time "10,84 SBU">
/trunk/blfs/xsoft/office/evolution/evolution-intro.xml
1,19 → 1,34
<sect2>
<title>Introduction à Evolution</title>
<title>Introduction à <application>Evolution</application></title>
 
<screen>Site de téléchargement (HTTP): <ulink url="&evolution-download-http;"/>
Site de téléchargement (FTP): <ulink url="&evolution-download-ftp;"/>
Version utilisée: &evolution-version;
Taille du package: &evolution-size;
Estimation de l'espace disque requis: &evolution-buildsize;</screen>
<para>Le package <application>Evolution</application> contient une suite
intégrée pour le mail, le calendrier et le carnet d'adresses.</para>
 
<para>Le package Evolution contient une suite intégrée mail, calendrier et
carnet d'adresse.</para>
<sect3><title>Informations sur le package</title>
<itemizedlist spacing='compact'>
<listitem><para>Téléchargement (HTTP): <ulink
url="&evolution-download-http;"/></para></listitem>
<listitem><para>Téléchargement (FTP): <ulink
url="&evolution-download-ftp;"/></para></listitem>
<listitem><para>Taille du téléchargement: &evolution-size;</para></listitem>
<listitem><para>Estimation de l'espace disque requis:
&evolution-buildsize;</para></listitem>
<listitem><para>Estimation du temps de construction:
&evolution-time;</para></listitem></itemizedlist>
</sect3>
 
<screen>evolution dépend de
<xref linkend="bonobo14"/>,
<xref linkend="bonobo-conf"/>, <xref linkend="gal"/>,
<xref linkend="libcapplet"/>, <xref linkend="gtkhtml"/>,
<xref linkend="soup"/>.</screen>
<sect3><title>Téléchargements supplémentaires</title>
<itemizedlist spacing='compact'>
<listitem><para>Application requise: <ulink
url="http://ftp2.nchu.edu.tw/UNIX/Database/BerkeleyDB/db-3.1.17.tar.gz"/></para></listitem>
</itemizedlist></sect3>
 
<sect3><title>Dépendances d'<application>Evolution</application></title>
<sect4><title>Requis</title>
<para><xref linkend="openssl"/>,
<xref linkend="libgnomeprintui"/> et <xref linkend="gtkhtml2"/></para></sect4>
<sect4><title>Optionnel</title>
<para><xref linkend="openldap"/> et <xref linkend="gtk-doc"/></para></sect4>
</sect3>
 
</sect2>
/trunk/blfs/xsoft/office/evolution/evolution-exp.xml
1,11 → 1,22
<sect2>
<title>Explication des commandes</title>
 
<para><userinput>--prefix=/opt/gnome</userinput> : Installe Evolution à
l'emplacement de Gnome 1.4.</para>
<para><option>--enable-compat185</option>: Construit le support pour d'anciens
fichiers de base de données.</para>
 
<para><userinput>--with-db3=/tmp</userinput> : Indique l'emplacement de
db-&db-3.1-version;.</para>
<para><parameter>--prefix=/opt/db-3.1.17</parameter>: Cette version de la base
de données Berkeley ne devrait pas être installée dans <filename
class="directory">/usr</filename>, car elle est seulement nécessaire pour
construire <application>Evolution</application>.</para>
 
<para><parameter>--with-db3=/opt/db-3.1.17</parameter>: Spécifie le répertoire
d'installation de db-3.1.17.</para>
 
<para><option>--enable-openssl</option>: Cette option compilera le support de
<acronym>SSL</acronym> dans <application>Evolution</application>.</para>
 
<para><option>--enable-openldap</option>: Cette option compilera le support de
<acronym>LDAP</acronym> dans <application>Evolution</application>.</para>
 
</sect2>
 
/trunk/blfs/xsoft/office/evolution/evolution-inst.xml
1,18 → 1,35
<sect2>
<title>Installation de evolution</title>
<title>Installation de <application>Evolution</application></title>
 
<para>Installez evolution en lançant les commandes suivantes:</para>
<note><para><application>Evolution</application> requiert
<application>Berkeley DB</application>-3.1.17. Les détails sur le
"pourquoi" sont dans le fichier <filename>README</filename> donné avec le code
source d'<application>Evolution</application>.
<application>Evolution</application> est lié statiquement à la bibliothèque,
donc ce livre installe <application>Berkeley DB</application>-3.1.17 dans <filename
class="directory">/opt</filename>, qui peut être supprimé une fois
<application>Evolution</application> installé.</para></note>
 
<!--
<note><para><xref linkend="db-3.1"></xref> must be installed
temporarily in order to install Evolution.</para></note>
-->
<para><screen><userinput>./configure --prefix=/opt/gnome --with-db3=/tmp &amp;&amp;
<para>Installez <application>Berkeley DB</application>-3.1.17 en lançant les
commandes suivantes:</para>
 
<screen><userinput><command>cd build_unix &amp;&amp;
../dist/configure --prefix=/opt/db-3.1.17 --enable-compat185
&amp;&amp;
make &amp;&amp;
make install</userinput></screen></para>
make install</command></userinput></screen>
 
<para>Si vous le souhiatez, vous pouvez supprimer db-&db-3.1-version;</para>
<para><screen><userinput>rm -rf /opt/db-&db-3.1-version;</userinput></screen></para>
<para>Installez <application>Evolution</application> en lançant les commandes
suivantes:</para>
 
<screen><userinput><command>./configure --prefix=$GNOME_PREFIX --with-db3=/opt/db-3.1.17 --enable-openssl &amp;&amp;
make &amp;&amp;
make install</command></userinput></screen>
 
<para>De manière optionnelle, vous pouvez supprimer <application>Berkeley
DB</application>-3.1.17 installé ci-dessus avec cette commande:</para>
 
<screen><userinput><command>rm -rf /opt/db-3.1.17</command></userinput></screen>
 
</sect2>
 
/trunk/blfs/xsoft/office/abiword/abiword-exp.xml
1,8 → 1,9
<sect2>
<title>Explications de la commande</title>
 
<para><command>--enable-gnome :</command> Cette commande demande à AbiWord
d'utiliser les bibliothèques GNOME.</para>
<para><command>--enable-gnome :</command> Cette commande demande à
<application>AbiWord</application> d'utiliser les bibliothèques
<application><acronym>GNOME</acronym></application>.</para>
 
</sect2>
 
/trunk/blfs/xsoft/office/abiword/abiword.ent
3,10 → 3,9
<!ENTITY AbiWord-inst SYSTEM "abiword-inst.xml">
<!ENTITY AbiWord-exp SYSTEM "abiword-exp.xml">
<!ENTITY AbiWord-desc SYSTEM "abiword-desc.xml">
<!ENTITY AbiWord-config SYSTEM "abiword-config.xml">
<!ENTITY AbiWord-buildsize "176,2 Mo">
<!ENTITY AbiWord-version "1.99.6">
<!ENTITY AbiWord-version "2.0.0">
<!ENTITY AbiWord-download-http "http://telia.dl.sourceforge.net/sourceforge/abiword/abiword-&AbiWord-version;.tar.bz2">
<!ENTITY AbiWord-download-ftp "">
<!ENTITY AbiWord-size "20,8 Mo">
<!ENTITY AbiWord-size "20,5 Mo">
<!ENTITY AbiWord-buildsize "164,7 Mo">
<!ENTITY AbiWord-time "1,82 SBU">
/trunk/blfs/xsoft/office/gnucash.xml
1,6 → 1,7
<sect1 id="gnucash" xreflabel="gnucash-&gnucash-version;">
<sect1 id="gnucash" xreflabel="GnuCash-&gnucash-version;">
<?dbhtml filename="gnucash.html" dir="xsoft"?>
<title>gnucash-&gnucash-version;</title>
<title>GnuCash-&gnucash-version;</title>
 
&gnucash-intro;
&gnucash-inst;
&gnucash-exp;
/trunk/blfs/xsoft/office/gnucash/gnucash-intro.xml
1,21 → 1,33
<sect2>
<title>Introduction à GnuCash</title>
<title>Introduction à <application>GnuCash</application></title>
 
<screen>Site de téléchargement (HTTP): <ulink url="&gnucash-download-http;"/>
Site de téléchargement (FTP): <ulink url="&gnucash-download-ftp;"/>
Version utilisée: &gnucash-version;
Taille du package: &gnucash-size;
Estimation de l'espace disque requis: &gnucash-buildsize;</screen>
<para><application>GnuCash</application> est un gestionnaire de finances
personnelles.</para>
 
<para>GnuCash est un gestionnaire de finances personnelles.</para>
<para>
<screen>gnucash dépend de
<xref linkend="gnome-print"/>, <xref linkend="libglade14"/>,
<xref linkend="db-3.3"/>, <xref linkend="gal"/>,
<xref linkend="libcapplet"/>, <xref linkend="gtkhtml"/>,
<xref linkend="libghttp"/>, <xref linkend="bonobo14"/>,
<xref linkend="guppi"/>, <xref linkend="guile"/>,
<xref linkend="slib"/>, <xref linkend="gwrap"/>.
</screen>
</para>
<sect3><title>Informations sur le package</title>
<itemizedlist spacing='compact'>
<listitem><para>Téléchargement (HTTP): <ulink
url="&gnucash-download-http;"/></para></listitem>
<listitem><para>Téléchargement (FTP): <ulink
url="&gnucash-download-ftp;"/></para></listitem>
<listitem><para>Taille du téléchargement: &gnucash-size;</para></listitem>
<listitem><para>Estimation de l'espace disque requis:
&gnucash-buildsize;</para></listitem>
<listitem><para>Estimation du temps de construction:
&gnucash-time;</para></listitem></itemizedlist>
</sect3>
<sect3><title>Dépendances de <application>GnuCash</application></title>
<sect4><title>Requis</title>
<para><xref linkend="gnome-print"></xref>, <xref
linkend="libglade14"></xref>, <xref linkend="db-3.3"></xref>,
<xref linkend="gal"></xref>, , <xref
linkend="gtkhtml"></xref>,
<xref linkend="libghttp"></xref>, <xref linkend="bonobo14"></xref>,
<xref linkend="guppi"></xref>,
<xref linkend="guile"></xref>, <xref linkend="slib"></xref> et <xref
linkend="gwrap"></xref></para></sect4>
</sect3>
 
 
</sect2>
/trunk/blfs/xsoft/office/gnucash/gnucash-exp.xml
1,8 → 1,9
<sect2>
<title>Explication des commandes</title>
 
<para><userinput>--prefix=/opt/gnome:</userinput>
La version &gnucash-version; de GnuCash est une application gnome 1.4.
<para><parameter>--prefix=/opt/gnome</parameter> :
La version &gnucash-version; de <application>GnuCash</application> est une
application <application><acronym>GNOME</acronym></application> 1.4.
</para>
 
</sect2>
/trunk/blfs/xsoft/office/gnucash/gnucash-inst.xml
1,11 → 1,11
<sect2>
<title>Installation de GnuCash</title>
<title>Installation de <application>GnuCash</application></title>
 
<para>Installez GnuCash en lançant les commandes suivantes:</para>
<para>Installez <application>GnuCash</application> en lançant les commandes suivantes:</para>
 
<para><screen><userinput>./configure --prefix=/opt/gnome &amp;&amp;
<screen><userinput><command>./configure --prefix=/opt/gnome &amp;&amp;
make &amp;&amp;
make install</userinput></screen></para>
make install</command></userinput></screen>
 
</sect2>
 
/trunk/blfs/xsoft/office/gnucash/gnucash-desc.xml
1,7 → 1,8
<sect2>
<title>Contenu</title>
 
<para>Le package GnuCash contient <userinput>gnucash.</userinput></para>
<para>Le package <application>GnuCash</application> contient
<command>gnucash</command>.</para>
 
</sect2>
 
8,7 → 9,8
<sect2><title>Description</title>
 
<sect3><title>GnuCash</title>
<para>gnucash est le gestionnaire de finances personnelles GnuCash.</para>
<para><command>gnucash</command> est le gestionnaire de finances
personnelles <application>GnuCash</application>.</para>
 
</sect3>
 
/trunk/blfs/xsoft/office/gnucash/gnucash-config.xml
1,12 → 1,14
<sect2>
<title>Configurer GnuCash</title>
<title>Configurer <application>GnuCash</application></title>
 
<sect3><title>Informations de configuration</title>
 
<note><para>GnuCash doit être lancé en tant que root une fois avant d'être
utilisé. Il suffit d'exécuter GnuCash à partir d'un terminal X et de cliquer sur
le bouton Cancel. Ceci doit être fait avant de configurer les comptes en tant
qu'utilisateur non privilégié, dû au fait que GnuCash doit créer des catalogues
<note><para><application>GnuCash</application> doit être lancé en tant que root
une fois avant d'être utilisé. Il suffit d'exécuter
<application>GnuCash</application> à partir d'un terminal
<application>X</application> et de cliquer sur le bouton Cancel. Ceci doit être
fait avant de configurer les comptes en tant qu'utilisateur non privilégié, dû
au fait que <application>GnuCash</application> doit créer des catalogues
scheme pour son utilisation propre avant d'être utilisé.</para></note>
 
</sect3>
/trunk/blfs/xsoft/office/gnucash/gnucash.ent
2,10 → 2,11
<!ENTITY gnucash-intro SYSTEM "gnucash-intro.xml">
<!ENTITY gnucash-inst SYSTEM "gnucash-inst.xml">
<!ENTITY gnucash-exp SYSTEM "gnucash-exp.xml">
<!ENTITY gnucash-config SYSTEM "gnucash-config.xml">
<!ENTITY gnucash-desc SYSTEM "gnucash-desc.xml">
<!ENTITY gnucash-config SYSTEM "gnucash-config.xml">
<!ENTITY gnucash-buildsize "144 Mo">
<!ENTITY gnucash-version "1.8.2">
<!ENTITY gnucash-download-http "http://www.gnucash.org/gnucash/sources/stable/gnucash-&gnucash-version;.tar.gz">
<!ENTITY gnucash-version "1.8.7">
<!ENTITY gnucash-download-http "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-&gnucash-version;.tar.gz">
<!ENTITY gnucash-download-ftp "">
<!ENTITY gnucash-size "6,3 Mo">
<!ENTITY gnucash-buildsize "144 Mo">
<!ENTITY gnucash-time "3,18 SBU">
/trunk/blfs/xsoft/office/gnumeric.xml
1,6 → 1,6
<sect1 id="gnumeric" xreflabel="gnumeric-&gnumeric-version;">
<sect1 id="gnumeric" xreflabel="Gnumeric-&gnumeric-version;">
<?dbhtml filename="gnumeric.html" dir="xsoft"?>
<title>gnumeric-&gnumeric-version;</title>
<title>Gnumeric-&gnumeric-version;</title>
 
&gnumeric-intro;
&gnumeric-inst;
/trunk/blfs/xsoft/office/gnumeric/gnumeric-intro.xml
1,7 → 1,7
<sect2>
<title>Introduction à <application>gnumeric</application></title>
<title>Introduction à <application>Gnumeric</application></title>
 
<para>Le package <application>gnumeric</application> contient un tableur. Ceci
<para>Le package <application>Gnumeric</application> contient un tableur. Ceci
est utile pour établir des analyses financières.</para>
 
<sect3><title>Informations sur le package</title>
17,10 → 17,9
&gnumeric-time;</para></listitem></itemizedlist>
</sect3>
 
<sect3><title>Dépendances de <application>gnumeric</application></title>
<sect3><title>Dépendances de <application>Gnumeric</application></title>
<sect4><title>Requis</title>
<para><xref linkend="libgnomeprintui"/> et <ulink
url="http://ftp.gnome.org/pub/gnome/sources/libgsf/1.8/libgsf-1.8.1.tar.bz2">libgsf-1.8.1</ulink></para></sect4>
<para><xref linkend="libgnomeprintui"/> et <xref linkend="libgsf"/></para></sect4>
<sect4><title>Optionnel</title>
<para>gda</para></sect4>
</sect3>
/trunk/blfs/xsoft/office/gnumeric/gnumeric-exp.xml
1,17 → 1,17
<sect2>
<title>Explication des commandes</title>
 
<para><command>--localstatedir=/var/lib</command> : Cette option place les
fichiers de scrollkeeper dans <filename>/var/lib/scrollkeeper</filename>
au lieu de <filename>$GNOME_PREFIX/var/scrollkeeper</filename>.</para>
<para><parameter>--localstatedir=/var/lib</parameter> : Cette option place les
fichiers de <application>ScrollKeeper</application> dans <filename class="directory">/var/lib/scrollkeeper</filename>
au lieu de <filename class="directory">$GNOME_PREFIX/var/scrollkeeper</filename>.</para>
 
<para><command>--sysconfdir=/etc/gnome</command> : Cette option place les
fichiers de configuration dans <filename>/etc/gnome</filename> au lieu de
<filename>$GNOME_PREFIX/etc</filename>.</para>
<para><parameter>--sysconfdir=/etc/gnome</parameter> : Cette option place les
fichiers de configuration dans <filename class="directory">/etc/gnome</filename> au lieu de
<filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
<para><command>--libexecdir=$GNOME_PREFIX/sbin</command> : Cette option place
les fichiers libexec dans <filename>$GNOME_PREFIX/sbin</filename> au lieu de
<filename>$GNOME_PREFIX/libexec</filename>.</para>
<para><parameter>--libexecdir=$GNOME_PREFIX/sbin</parameter> : Cette option place
les fichiers libexec dans <filename class="directory">$GNOME_PREFIX/sbin</filename> au lieu de
<filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
</sect2>
 
/trunk/blfs/xsoft/office/gnumeric/gnumeric-inst.xml
1,7 → 1,7
<sect2>
<title>Installation de <application>gnumeric</application></title>
<title>Installation de <application>Gnumeric</application></title>
 
<para>Installez <application>gnumeric</application> en lançant les commandes
<para>Installez <application>Gnumeric</application> en lançant les commandes
suivantes:</para>
 
<screen><userinput><command>./configure --prefix=$GNOME_PREFIX --localstatedir=/var/lib \
/trunk/blfs/xsoft/office/gnumeric/gnumeric-desc.xml
1,7 → 1,7
<sect2>
<title>Contenu</title>
 
<para>Le package <application>gnumeric</application> contient
<para>Le package <application>Gnumeric</application> contient
<command>gnumeric</command>.</para>
 
</sect2>
9,7 → 9,8
<sect2><title>Description</title>
 
<sect3><title>gnumeric</title>
<para><command>gnumeric</command> est le tableur de GNOME.</para></sect3>
<para><command>gnumeric</command> est le tableur de
<application><acronym>GNOME</acronym></application>.</para></sect3>
 
 
</sect2>
/trunk/blfs/xsoft/office/gnumeric/gnumeric.ent
3,10 → 3,9
<!ENTITY gnumeric-inst SYSTEM "gnumeric-inst.xml">
<!ENTITY gnumeric-exp SYSTEM "gnumeric-exp.xml">
<!ENTITY gnumeric-desc SYSTEM "gnumeric-desc.xml">
<!ENTITY gnumeric-config SYSTEM "gnumeric-config.xml">
<!ENTITY gnumeric-buildsize "241,5 Mo">
<!ENTITY gnumeric-version "1.1.20">
<!ENTITY gnumeric-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnumeric/1.1/gnumeric-&gnumeric-version;.tar.bz2">
<!ENTITY gnumeric-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/gnumeric/1.1/gnumeric-&gnumeric-version;.tar.bz2">
<!ENTITY gnumeric-size "10,3 Mo">
<!ENTITY gnumeric-time "2,97 SBU">
<!ENTITY gnumeric-version "1.2.0">
<!ENTITY gnumeric-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnumeric/1.2/gnumeric-&gnumeric-version;.tar.bz2">
<!ENTITY gnumeric-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/gnumeric/1.2/gnumeric-&gnumeric-version;.tar.bz2">
<!ENTITY gnumeric-size "10,5 Mo">
<!ENTITY gnumeric-buildsize "247,6 Mo">
<!ENTITY gnumeric-time "2,81 SBU">
/trunk/blfs/xsoft/office/magicpoint.xml
2,7 → 2,7
<?dbhtml filename="magicpoint.html" dir="xsoft"?>
<title>magicpoint</title>
 
<para>A FAIRE</para>
<para>TO BE DONE</para>
 
</sect1>
 
/trunk/blfs/xsoft/office/office.xml
2,6 → 2,11
<?dbhtml filename="office.html" dir="xsoft"?>
<title>Programmes de bureau individuels</title>
 
<para>Ce chapitre est une collection de projets indépendants qui peuvent être
installés suivant des besoins spécifiques. Ensemble, ils créent une suite office
respectable. Bien qu'ils soient déficients sur la cohérence de l'interface
utilisateur, ils excellent sur la seule chose qu'ils ont à faire.</para>
 
&AbiWord;
&gnumeric;
&gnucash;
/trunk/blfs/xsoft/office/gimp.xml
1,8 → 1,12
<sect1 id="gimp" xreflabel="gimp">
<sect1 id="gimp" xreflabel="GIMP-&gimp-version;">
<?dbhtml filename="gimp.html" dir="xsoft"?>
<title>gimp</title>
<title>GIMP-&gimp-version;</title>
 
<para>A FAIRE</para>
&gimp-intro;
&gimp-inst;
&gimp-exp;
&gimp-config;
&gimp-desc;
 
</sect1>
 
/trunk/blfs/xsoft/office/gimp/gimp.ent
2,10 → 2,11
<!ENTITY gimp-intro SYSTEM "gimp-intro.xml">
<!ENTITY gimp-inst SYSTEM "gimp-inst.xml">
<!ENTITY gimp-exp SYSTEM "gimp-exp.xml">
<!ENTITY gimp-config SYSTEM "gimp-config.xml">
<!ENTITY gimp-desc SYSTEM "gimp-desc.xml">
<!ENTITY gimp-config SYSTEM "gimp-config.xml">
<!ENTITY gimp-version "1.2.5">
<!ENTITY gimp-download-http "http://gd.tuwien.ac.at/graphics/gimp/gimp/v1.2/v&gimp-version;/gimp-&gimp-version;.tar.bz2">
<!ENTITY gimp-download-ftp "ftp://ftp.gimp.org/pub/gimp/v1.2/v&gimp-version;/gimp-&gimp-version;.tar.bz2">
<!ENTITY gimp-size "10,6 Mo">
<!ENTITY gimp-buildsize "226 Mo">
<!ENTITY gimp-version "1.2.3">
<!ENTITY gimp-download-http "">
<!ENTITY gimp-download-ftp "ftp://ftp.gimp.org/pub/gimp/v1.2/v1.2.3/gimp-1.2.3.tar.bz2">
<!ENTITY gimp-size "10,6 Mo">
<!ENTITY gimp-time "3,62 SBU">
/trunk/blfs/xsoft/office/gimp/gimp-intro.xml
1,24 → 1,43
<sect2>
<title>Introduction à gimp</title>
<title>Introduction à <application><acronym>GIMP</acronym></application></title>
 
<screen>Site de téléchargement (HTTP): <ulink url="&gimp-download-http;"/>
Site de téléchargement (FTP): <ulink url="&gimp-download-ftp;"/>
Version utilisée: &gimp-version;
Taille du package: &gimp-size;
Estimation de l'espace disque requis: &gimp-buildsize;</screen>
<para>Le package <application><acronym>GIMP</acronym></application> contient le
programme de manipulation d'images <acronym>GNU</acronym>. C'est utile pour
retoucher des photos, composer des images.</para>
 
<screen>Téléchargements supplémentaires:
<ulink url="ftp://ftp.gimp.org/pub/gimp/fonts/freefonts-0.10.tar.gz"/>
<ulink
url="ftp://ftp.gimp.org/pub/gimp/v1.2/v1.2.3/gimp-data-extras-1.2.0.tar.bz2"/></screen>
<sect3><title>Informations sur le package</title>
<itemizedlist spacing='compact'>
<listitem><para>Téléchargement (HTTP): <ulink
url="&gimp-download-http;"/></para></listitem>
<listitem><para>Téléchargement (FTP): <ulink
url="&gimp-download-ftp;"/></para></listitem>
<listitem><para>Taille du téléchargement: &gimp-size;</para></listitem>
<listitem><para>Estimation de l'espace disque requis:
&gimp-buildsize;</para></listitem>
<listitem><para>Estimation du temps de construction:
&gimp-time;</para></listitem></itemizedlist>
</sect3>
 
<para>Le package gimp contient le programme de manipulation d'image GNU (GNU
Image Manipulation Program). Il est utile pour retoucher des photos, composer
des images et en créer.</para>
<sect3><title>Téléchargements supplémentaires</title>
<itemizedlist spacing='compact'>
<listitem><para>Téléchargement (FTP): <ulink
url="ftp://ftp.gimp.org/pub/gimp/fonts/freefonts-0.10.tar.gz"/></para></listitem>
<listitem><para>Téléchargement (FTP): <ulink
url="ftp://ftp.gimp.org/pub/gimp/v1.2/v1.2.5/gimp-data-extras-1.2.0.tar.bz2"/></para></listitem></itemizedlist>
</sect3>
<sect3><title>Dépendances de <application><acronym>GIMP</acronym></application></title>
<sect4><title>Requis</title>
<para><xref linkend="GTK"/></para></sect4>
<sect4><title>Optionnel</title>
<para><xref linkend="libtiff"/>, <xref linkend="libpng"/>, <xref
linkend="libjpeg"/>,
<ulink url="http://gimp-print.sourceforge.net/">gimp-print</ulink>,
<xref linkend="aalib"/>, <ulink
url="http://starship.python.net/~gward/mpeglib/mpeg_lib-1.3.1.tar.gz">mpeg_lib-1.3.1</ulink>,
<xref linkend="Python"/> et
<xref linkend="perl-modules"/>:Gtk-Perl-&Gtk-Perl-version;,
PDL-&PDL-version; et Parse-RecDescent-&Parse-RecDescent-version;</para></sect4>
</sect3>
 
<screen>gimp dépend de
<xref linkend="GTK"/>
gimp utilisera
<xref linkend="libtiff"/>, <xref linkend="libpng"/>, <xref linkend="libjpeg"/>, <xref linkend="aalib"/>, <ulink url="http://starship.python.net/~gward/mpeglib/mpeg_lib-1.3.1.tar.gz">mpeg_lib-1.3.1</ulink>, <xref linkend="Python"/> et <xref linkend="perl-modules"/>:Gtk-Perl-&Gtk-Perl-version;, PDL-&PDL-version; et Parse-RecDescent-&Parse-RecDescent-version;</screen>
 
</sect2>
/trunk/blfs/xsoft/office/gimp/gimp-exp.xml
0,0 → 1,11
<sect2>
<title>Explication des commandes</title>
 
<para><option>--disable-print</option>: Cette option est nécessaire quand
<application>gimp-print</application> n'est pas installé. Si
<application>gimp-print</application> est installé, cette option pourra être
supprimé.
</para>
 
</sect2>
 
/trunk/blfs/xsoft/office/gimp/gimp-inst.xml
1,11 → 1,12
<sect2>
<title>Installation of gimp</title>
<title>Installation de <application><acronym>GIMP</acronym></application></title>
 
<para>Install gimp by running the following commands:</para>
<para>Installez <application><acronym>GIMP</acronym></application> en lançant
les commandes suivantes:</para>
 
<para><screen><userinput>./configure --prefix=/usr --sysconfdir=/etc &amp;&amp;
<screen><userinput><command>./configure --prefix=/usr --sysconfdir=/etc --disable-print &amp;&amp;
make &amp;&amp;
make install</userinput></screen></para>
make install</command></userinput></screen>
 
 
</sect2>
/trunk/blfs/xsoft/office/gimp/gimp-desc.xml
1,9 → 1,9
<sect2>
<title>Contents</title>
<title>Contenu</title>
 
<para>The gimp package contains <userinput>gimp</userinput>,
<userinput>escputil</userinput>, <userinput>gimp-config</userinput>
and <userinput>gimp-remote</userinput>.</para>
<para>Le package <application><acronym>GIMP</acronym></application> contient
<command>gimp</command>, <command>escputil</command>,
<command>gimp-config</command> et <command>gimp-remote</command>.</para>
 
</sect2>
 
10,20 → 10,23
<sect2><title>Description</title>
 
<sect3><title>gimp</title>
<para>gimp is an image manipulation program. It works with a variety of
image formats and provides a large selection of tools.</para></sect3>
<para><command>gimp</command> est un programme de manipulation d'images. Il
fonctionne avec une variété de formats d'images et fournit une grande sélection
d'outils.</para>
</sect3>
 
<sect3><title>escputil</title>
<para>escputil is a utility to perform maintenance tasks on an Epson
Stylus inkjet printer.</para></sect3>
<para><command>escputil</command> est un outil réalisant des tâches de
maintenance sur une imprimante à jet d'encre Epson Stylus.</para></sect3>
 
<sect3><title>gimp-config</title>
<para>gimp-config is used by other programs that want to link to gimp
libraries.</para></sect3>
<para><command>gimp-config</command> est utilisé par d'autres programmes qui
souhaitent être liés aux bibliothèques <application><acronym>GIMP</acronym></application>.</para></sect3>
 
<sect3><title>gimp-remote</title>
<para>gimp-remote is a small utility that tells a running gimp to open a
local or remote image file.</para></sect3>
<para><command>gimp-remote</command> est un petit outil indiquant à un
<application><acronym>GIMP</acronym></application> en cours d'exécution
d'ouvrir une image en local ou à distance.</para></sect3>
 
</sect2>
 
/trunk/blfs/xsoft/office/gimp/gimp-config.xml
1,5 → 1,5
<sect2>
<title>Configurer gimp</title>
<title>Configurer <application><acronym>GIMP</acronym></application></title>
 
<sect3><title>Fichiers de configuration</title>
<para><filename>~/.gimp-1.2</filename></para>
7,8 → 7,9
 
<sect3><title>Informations de configuration</title>
 
<para>GIMP exécute un assistant de configuration pour chaque utilisateur lors
de leur première utilisation du programme.</para>
<para><application><acronym>GIMP</acronym></application> exécute un assistant
de configuration pour chaque utilisateur lors de leur première utilisation du
programme.</para>
</sect3>
 
</sect2>
/trunk/blfs/xsoft/suites/koffice.xml
1,54 → 1,9
<sect1 id="koffice">
<?dbhtml filename="koffice.html" dir="xsoft"?>
<title>koffice-&koffice-version;</title>
<title>KOffice-&koffice-version;</title>
 
<para>
<screen>Site de téléchargement: <ulink url="&koffice-download;"/>
Version utilisée: &koffice-version;
Taille du package: &koffice-size;
Espace disque pour la construction: 133 Mo
Espace disque après l'installation: 35 Mo</screen></para>
&koffice-intro;
&koffice-inst;
&koffice-desc;
 
<para>KOffice est la suite office intégrée de KDE.</para>
 
<para><screen>KOffice dépend de
<xref linkend="kde-base"/>.</screen></para>
 
<para>KOffice dispose aussi de packages d'internationalisation, nommé de cette
façon:
<screen>koffice-i18n-xx-&koffice-version;.tar.bz2</screen>
où xx sont les deux à cinq lettre de code du pays concerné. La taille de ces
fichiers va de 289Ko à 408Ko.</para>
 
 
<para>Installez koffice avec:
<screen><userinput>./configure --prefix=&kde-dir; --disable-debug &amp;&amp;
make &amp;&amp;
make install</userinput></screen></para>
<sect2><title>Explications des commandes d'installation de koffice</title>
<para>Les options sont les mêmes que pour kde-base et ne sont donc pas répétées
ici.</para>
</sect2>
<sect2><title>Configurer koffice</title>
<para>Il n'existe pas de configuration explicite du package koffice.</para>
</sect2>
<sect2>
<title>Contenu</title>
<para>Le package KOffice apporte:</para>
<itemizedlist>
<listitem><para>KWord - traitement de texte style Framemaker</para></listitem>
<listitem><para>KSpread - tableur (scriptable)</para></listitem>
<listitem><para>KPresenter - Programme d'affichage et de construction de présentation</para></listitem>
<listitem><para>Kivio - Flowchart program</para></listitem>
<listitem><para>Kontour - Programme de dessin vectoriel</para></listitem>
<listitem><para>Krita - Programme de dessin bitmap</para></listitem>
<listitem><para>Kugar - Un outil pour créer des rapports</para></listitem>
<listitem><para>KPlato - Application de gestion de projets (tout début du développement)</para></listitem>
<listitem><para>KChart - Chart drawing application</para></listitem>
<listitem><para>KFormula - Editeur de formules</para></listitem>
</itemizedlist>
</sect2>
</sect1>
/trunk/blfs/xsoft/suites/koffice/koffice-inst.xml
0,0 → 1,12
<sect2>
<title>Installation de <application>KOffice</application></title>
 
<para>Installez <application>KOffice</application> en lançant les commandes
suivantes:</para>
 
<screen><userinput><command>export QTDIR=/opt/qt
./configure --prefix=&kde-dir; --disable-debug &amp;&amp;
make &amp;&amp;
make install</command></userinput></screen>
 
</sect2>
/trunk/blfs/xsoft/suites/koffice/koffice-desc.xml
0,0 → 1,54
<sect2>
<title>Contenu</title>
<para>Le package <application>KOffice</application> fournit
<command>kword</command>,
<command>kspread</command>,
<command>kpresenter</command>,
<command>kivio</command>,
<command>kontour</command>,
<command>krita</command>,
<command>kugar</command>,
<command>kplato</command>,
<command>kchart</command> et
<command>kformula</command>.
</para>
 
<sect3><title>kword</title>
<para><command>kword</command> est un traitement de texte du type framemaker
ainsi qu'un programme de publication.</para></sect3>
 
<sect3><title>kspread</title>
<para><command>kspread</command> est un tableur scriptable.
</para></sect3>
 
<sect3><title>kpresenter</title>
<para><command>kpresenter</command> est un programme de présentation.
</para></sect3>
 
<sect3><title>kivio</title>
<para><command>kivio</command> est un programme de création de diagrammes.</para></sect3>
 
<sect3><title>kontour</title>
<para><command>kontour</command> est un programme de dessins vectoriels.
</para></sect3>
 
<sect3><title>krita</title>
<para><command>krita</command> est un programme de dessin et d'édition d'images.
</para></sect3>
 
<sect3><title>kugar</title>
<para><command>kugar</command> est un outil de création de rapports.
</para></sect3>
 
<sect3><title>kplato</title>
<para><command>kplato</command> est une application de gestion des projets
(encore dans son étape de développement).</para></sect3>
 
<sect3><title>kchart</title>
<para><command>kchart</command> est un application de création de diagrammes.
</para></sect3>
 
<sect3><title>kformula</title>
<para><command>kformula</command> est un éditeur de formules.</para></sect3>
 
</sect2>
/trunk/blfs/xsoft/suites/koffice/koffice.ent
1,5 → 1,10
<!ENTITY koffice SYSTEM "../koffice.xml">
<!ENTITY koffice-version "1.2.1">
<!ENTITY koffice-download "ftp://ftp.kde.org/pub/kde/stable/koffice-1.2.1/src/koffice-1.2.1.tar.bz2">
<!ENTITY koffice-size "8,9 Mo">
<!ENTITY koffice-buildsize "143 Mo">
<!ENTITY koffice-intro SYSTEM "koffice-intro.xml">
<!ENTITY koffice-inst SYSTEM "koffice-inst.xml">
<!ENTITY koffice-desc SYSTEM "koffice-desc.xml">
<!ENTITY koffice-version "1.2.93">
<!ENTITY koffice-download-http "http://download.at.kde.org/pub/kde/unstable/koffice-&koffice-version;/src/koffice-&koffice-version;.tar.bz2">
<!ENTITY koffice-download-ftp "ftp://ftp.kde.org/pub/kde/unstable/koffice-&koffice-version;/src/koffice-&koffice-version;.tar.bz2">
<!ENTITY koffice-size "10,3 Mo">
<!ENTITY koffice-buildsize "181 Mo">
<!ENTITY koffice-time "30,8 SBU">
/trunk/blfs/xsoft/suites/koffice/koffice-intro.xml
0,0 → 1,33
<sect2><title>Introduction à <application>KOffice</application></title>
 
<para><application>KOffice</application> est la suite office intégrée pour
<acronym>KDE</acronym>.</para>
 
<sect3><title>Informations sur le package</title>
<itemizedlist spacing='compact'>
<listitem><para>Téléchargement (HTTP): <ulink
url="&koffice-download-http;"/></para></listitem>
<listitem><para>Téléchargement (FTP): <ulink
url="&koffice-download-ftp;"/></para></listitem>
<listitem><para>Taille du téléchargement: &koffice-size;</para></listitem>
<listitem><para>Estimation de l'espace disque requis:
&koffice-buildsize;</para></listitem>
<listitem><para>Estimation du temps de construction:
&koffice-time;</para></listitem>
</itemizedlist>
</sect3>
 
<sect3><title>Dépendances de <application>KOffice</application></title>
<sect4><title>Requis</title>
<para><xref linkend="kde-base"/></para></sect4>
</sect3>
</sect2>
 
<sect2><title>Téléchargements supplémentaires</title>
 
<para>KOffice a plusieurs packages d'internationalisation disponibles sous cette
forme:
<screen>koffice-i18n-xx-&koffice-version;.tar.bz2</screen>
où xx correspond à entre deux et cinq lettres du code du pays impliqué. La
taille du fichier peut aller de 0,4 Mo à 3,7 Mo.</para>
</sect2>
/trunk/blfs/xsoft/suites/suites.xml
2,6 → 2,11
<?dbhtml filename="suites.html" dir="xsoft"?>
<title>Suites Office</title>
 
<para>Ce chapitre contient des applications qui contiennent tous les besoins
essentiels des travailleurs quotidiens sur un seul "petit" package. Les
bénéfices sont une interface utilisateur consistante et une coopération entre
les applications.</para>
 
&koffice;
&openoffice;
 
/trunk/blfs/xsoft/suites/openoffice.xml
1,6 → 1,6
<sect1 id="openoffice" xreflabel="openoffice-&openoffice-version;">
<sect1 id="openoffice" xreflabel="OpenOffice-&openoffice-version;">
<?dbhtml filename="openoffice.html" dir="xsoft"?>
<title>openoffice-&openoffice-version;</title>
<title>OpenOffice-&openoffice-version;</title>
 
&openoffice-intro;
&openoffice-inst;
/trunk/blfs/xsoft/suites/openoffice/openoffice.ent
3,10 → 3,9
<!ENTITY openoffice-inst SYSTEM "openoffice-inst.xml">
<!ENTITY openoffice-exp SYSTEM "openoffice-exp.xml">
<!ENTITY openoffice-desc SYSTEM "openoffice-desc.xml">
<!ENTITY openoffice-buildsize "2,1 Go">
<!ENTITY openoffice-version "1.0.2">
<!ENTITY openoffice-download-http "http://sf1.mirror.openoffice.org/stable/&openoffice-version;/OOo_&openoffice-version;_source.tar.bz2">
<!ENTITY openoffice-version "1.1.0">
<!ENTITY openoffice-download-http "http://www.openoffice.org/dev_docs/source/&openoffice-version;/source.html">
<!ENTITY openoffice-download-ftp "">
<!ENTITY openoffice-buildtime "14 heures (850 MHz)">
<!ENTITY openoffice-installsize "203 Mo">
<!ENTITY openoffice-size "155 Mo">
<!ENTITY openoffice-buildsize "3,0 Go">
<!ENTITY openoffice-time "">
/trunk/blfs/xsoft/suites/openoffice/openoffice-intro.xml
1,55 → 1,51
<sect2>
<title>Introduction à openoffice</title>
<title>Introduction à <application>OpenOffice</application></title>
 
<screen>Site de téléchargement (HTTP): <ulink url="&openoffice-download-http;"/>
Site de téléchargement (FTP): <ulink url="&openoffice-download-ftp;"/>
Version utilisée: &openoffice-version;
Taille du package: &openoffice-size;
Estimation de l'espace disque requis: &openoffice-buildsize;
Estimation du temps de construction: &openoffice-buildtime;
Estimation de la taille d'instllation: &openoffice-installsize;</screen>
<para><application>OpenOffice</application> est une suite office, la
contre-partie Open Source de <application>StarOffice</application>.</para>
 
<para>openoffice est une suite office, la contre-partie opensource de
StarOffice.</para>
<sect3><title>Informations sur le package</title>
<itemizedlist spacing='compact'>
<listitem><para>Téléchargement (HTTP): <ulink
url="&openoffice-download-http;"/></para></listitem>
<listitem><para>Téléchargement (FTP): <ulink
url="&openoffice-download-ftp;"/></para></listitem>
<listitem><para>Taille du téléchargement: &openoffice-size;</para></listitem>
<listitem><para>Estimation de l'espace disque requis:
&openoffice-buildsize;</para></listitem>
<listitem><para>Estimation du temps de construction:
&openoffice-time;</para></listitem>
</itemizedlist>
</sect3>
 
<screen>openoffice dépend de
<xref linkend="freetype2"/>,
<xref linkend="xfree86"/>,
<xref linkend="j2sdk"/>,
<xref linkend="zip"/>,
<xref linkend="unzip"/>,
<xref linkend="tcsh"/>,
<xref linkend="db"/>,
<xref linkend="STLport"/>,
<xref linkend="which"/>
et <ulink url="http://www.courtesan.com/mktemp">mktemp</ulink>
openoffice utilisera:
ant
</screen>
<sect3><title>Dépendances d'<application>OpenOffice</application></title>
<sect4><title>Requis</title>
<para><xref linkend="xfree86"/>, <xref linkend="j2sdk"/>,
<xref linkend="zip"/>, <xref linkend="unzip"/>, <xref linkend="tcsh"/>,
<xref linkend="which"/></para></sect4>
<sect4><title>Optionnel</title>
<para><xref linkend="Linux_PAM"/> et <ulink
url="http://ant.apache.org/">Apache Ant</ulink></para></sect4>
</sect3>
 
<para>Téléchargez la bibliothèque 'General Polygon Clipper' à partir de <ulink
url="ftp://ftp.cs.man.ac.uk/pub/toby/gpc/gpc231.tar.Z"/>.</para>
 
<para>Téléchargez aussi les différents correctifs à partir de
<userinput><ulink url="&hfile-root;"/></userinput>.
Les correctifs commencent avec openoffice-&openoffice-version;.
Vous aurez besoin de la plupart des correctifs, à part ceux qui activent
l'utilisation de packages déjà installés sur le système (vous devez sélectionner
ceux basé sur votre installation).</para>
 
<para>L'archive tar des sources contient seulement une aide en langue anglaise.
Un fichier d'aide localisée peut être disponible sur <ulink
url="http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/helpcontent/"/>.</para>
 
<para>Si vous avez des difficultés en construisant openoffice, vérifiez l'astuce
openoffice pour plus d'informations sur <ulink
url="http://www.linuxfromscratch.org/~tushar/"/>. Cette astuce discute aussi de
l'installation de programmes auxiliaires.</para>
 
<!--
<note><para>Il reste un problème avec la version actuelle de OO sur LFS. La
construction et l'installation semblent réussir mais aucun fichier n'est
installé. Le problème est en cours de résolution.</para></note>
-->
 
<sect3><title>Téléchargements supplémentaires</title>
<itemizedlist spacing='compact'>
<listitem><para>Bibliothèque General Polygon Clipper (Requis): <ulink
url="ftp://ftp.cs.man.ac.uk/pub/toby/gpc/gpc231.tar.Z"/></para></listitem>
<listitem><para>Correctif requis (désactive la construction du carnet d'adresses
de mozilla addressbook): <ulink
url="&patch-root;/openoffice-&openoffice-version;-no-mozab.patch"/></para></listitem>
<listitem><para>Correctif requis (l'exécutable <command>test</command> se trouve
dans <filename class="directory">/bin</filename>,
not in <filename class="directory">/usr/bin</filename>): <ulink
url="&patch-root;/openoffice-&openoffice-version;-test-bin-loc.patch"/></para></listitem>
<listitem><para>Correctif requis si <xref linkend="Linux_PAM"/> n'est pas installé: <ulink
url="&patch-root;/openoffice-&openoffice-version;-no-pam.patch"/></para></listitem>
<listitem><para>Correctif requis si vous compilez avec <acronym>JDK</acronym> 1.4.2: <ulink
url="&patch-root;/openoffice-&openoffice-version;-jdk-1.4.2-fix.patch"/></para></listitem>
<listitem><para>L'archive source <acronym>TAR</acronym> contient seulement
l'aide en anglais. Le fichier contenant l'aide localisé pourrait être disponible
sur <ulink
url="http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/helpcontent/"/>.</para></listitem></itemizedlist>
</sect3>
</sect2>
/trunk/blfs/xsoft/suites/openoffice/openoffice-exp.xml
2,22 → 2,22
<title>Explications des commandes</title>
 
<para>
<userinput>mv ../gpc231/gpc.* external/gpc</userinput> : Copie les fichiers
<command>mv ../gpc231/gpc.* external/gpc</command> : Copie les fichiers
gpc à l'emplacement adéquate.</para>
 
<para><userinput>--with-lang=ENUS</userinput> : Compile en anglais US, vous
<para><parameter>--with-lang=ENUS</parameter> : Compile en anglais US, vous
pouvez mettre en place plus de langages, ou tous.</para>
 
<para><userinput>./bootstrap</userinput> : Création des packages requis pour
<para><command>./bootstrap</command> : Création des packages requis pour
le bootstrap lors de la construction.</para>
 
<para><userinput>dmake</userinput> : Compile le package.</para>
<para><command>dmake</command> : Compile le package.</para>
 
<para><userinput>sed -e "s:^oo_home=...</userinput> : Supprime le répertoire
<para><command>sed -e "s:^oo_home=...</command> : Supprime le répertoire
d'installation spécifique à la version.</para>
 
<para><userinput>for appl in swriter scalc sdraw simpress smath soffice;
do ...</userinput> : Crée les liens pour que le package puisse être lancé
<para><command>for appl in swriter scalc sdraw simpress smath soffice;
do ...</command> : Crée les liens pour que le package puisse être lancé
de la ligne de commande sans modifier le chemin existant.</para>
 
</sect2>
/trunk/blfs/xsoft/suites/openoffice/openoffice-inst.xml
1,21 → 1,13
<sect2>
<title>Installation de openoffice</title>
<title>Installation de <application>OpenOffice</application></title>
 
<para>Notez qu'openoffice pose problème avec
<application>bison-1.875</application>. Vous pouvez soit télécharger
<application>bison-1.75</application> soit installer
<application>bison-1.75</application> en indiquant un autre préfixe
(c'est-à-dire <filename>/opt/bison-1.75</filename>) et placez
<filename class="directory">$bison_prefix/bin</filename> en tant que première
entrée de <envar>PATH</envar>.</para>
 
<para>Appliquez les correctifs téléchargés et copiez les fichiers gpc.</para>
 
<para><screen><userinput>mv ../gpc231/* external/gpc &amp;&amp;
<screen><userinput><command>mv ../gpc231/* external/gpc &amp;&amp;
rm -rf ../gpc231 &amp;&amp;
for p in ../openoffice-&openoffice-version;-*.patch
do patch -Np1 -i $p
done</userinput></screen></para>
done</command></userinput></screen>
 
<para>Si vous voulez optimiser la construction, éditez
<filename>solenv/inc/unxlngi4.mk</filename> et ajoutez les options
24,15 → 16,11
est de ne pas utiliser d'optimisation personnalisé. La commande suivante
supprime une option -mcpu incorrecte dans le fichier ci-dessus.</para>
 
<para><screen><userinput>cd solenv/inc &amp;&amp;
cp unxlngi3.mk unxlngi3.mk.orig &amp;&amp;
sed -e "s:^CFLAGSOPT=.*:CFLAGSOPT=${CFLAGS}:g" \
unxlngi3.mk.orig &gt; unxlngi3.mk &amp;&amp;
<screen><userinput><command>cd solenv/inc &amp;&amp;
cp unxlngi4.mk unxlngi4.mk.orig &amp;&amp;
sed -e "s:^CFLAGSOPT=.*:CFLAGSOPT=${CFLAGS}:g" \
-e "s:\-mcpu=pentiumpro::" \
sed -e "s:\-mcpu=pentiumpro::" \
unxlngi4.mk.orig &gt; unxlngi4.mk &amp;&amp;
cd ../..</userinput></screen></para>
cd ../..</command></userinput></screen>
 
<para>Configurez openoffice en utilisant les commandes suivantes. Vous pouvez
ajouter des langages suivant vos préférences. Si un composant particulier n'est
39,21 → 27,24
pas disponible dans la langue de votre choix, il sera par défaut en anglais.
</para>
 
<para><screen><userinput>cd config_office/ &amp;&amp;
./configure --with-lang=ENUS --with-stlport4-home=/usr &amp;&amp;
cd .. &amp;&amp;
source LinuxIntelEnv.Set.sh</userinput></screen></para>
<screen><userinput><command>cd config_office/ &amp;&amp;
./configure --with-lang=ALL &amp;&amp;
cd ..</command></userinput></screen>
 
<para>Compilez openoffice en utilisant les commandes suivantes.</para>
<para>Compilez <application>OpenOffice</application> en utilisant les commandes suivantes.</para>
 
<para><screen><userinput>./bootstrap &amp;&amp;
dmake</userinput></screen></para>
<note><para>Openoffice échoue à la compilation si umask est initialisé sur
quelque chose d'exotique. Initialisez-le à 022 si vous l'initialisez
habituellement sur autre chose.</para></note>
 
<screen><userinput><command>./bootstrap &amp;&amp;
bash -c "source LinuxIntelEnv.Set.sh; dmake"</command></userinput></screen>
 
<para>Si vous avez téléchargé les fichiers compressés d'aide localisé, vous
aurez besoin de les décompresser dans le répertoire approprié comme
mentionné ci-dessous et de recréer l'ensemble d'installation.</para>
 
<para><screen><userinput>cd solver/641/unxlngi4.pro/pck &amp;&amp;
<screen><userinput><command>cd solver/645/unxlngi4.pro/pck &amp;&amp;
for i in $(ls ../../../../../helpcontent_*_unix.tgz)
do
tar -xvzf $i
60,23 → 51,24
done &amp;&amp;
cd ../../../../instsetoo &amp;&amp;
rm -rf unxlngi4.pro &amp;&amp;
dmake &amp;&amp;
cd ..</userinput></screen></para>
cd .. &amp;&amp;
bash -c "source LinuxIntelEnv.Set.sh ; dmake"</command></userinput></screen>
 
<para>Installez OpenOffice en utilisant les commandes suivantes. Les commandes
suivantes installent le nécessaire pour la langue anglaise. Pour installer une
version localisée, remplacez le 01 par le code international téléphonique de
votre pays. Notez qu'un affichage X est nécessaire lors de l'installation bien
qu'aucune fenêtre X ne sera visible. Vous pouvez utiliser Xvfb si vous compilez
à partir de la console.</para>
<para>Installez <application>OpenOffice</application> en utilisant les
commandes suivantes. Les commandes suivantes installent le nécessaire pour la
langue anglaise. Pour installer une version localisée, remplacez le 01 par le
code international téléphonique de votre pays. Notez qu'un affichage
<application>X</application> est nécessaire lors de l'installation bien
qu'aucune fenêtre <application>X</application> ne sera visible. Vous pouvez
utiliser <application>Xvfb</application> si vous compilez à partir de la console.</para>
 
<para><screen><userinput>cd instsetoo/unxlngi4.pro/01/normal &amp;&amp;
<screen><userinput><command>cd instsetoo/unxlngi4.pro/01/normal &amp;&amp;
cp install install.orig &amp;&amp;
sed -e "s:^oo_home=.*:oo_home=openoffice:" install.orig > install &amp;&amp;
./install --prefix=/opt &amp;&amp;
for appl in swriter scalc sdraw simpress smath soffice
for appl in swriter scalc sdraw simpress smath soffice spadmin
do ln -sf /opt/openoffice/program/$appl /usr/bin/$appl
done</userinput></screen></para>
done</command></userinput></screen>
 
</sect2>
 
/trunk/blfs/xsoft/suites/openoffice/openoffice-desc.xml
1,9 → 1,10
<sect2>
<title>Contenu</title>
 
<para>Le package openoffice contient <userinput>swriter</userinput>,
<userinput>simpress</userinput>, <userinput>scalc</userinput>,
<userinput>sdraw</userinput>, <userinput>smath</userinput>.</para>
<para>Le package <application>OpenOffice</application> contient
<command>swriter</command>,
<command>simpress</command>, <command>scalc</command>,
<command>sdraw</command>, <command>smath</command>.</para>
 
</sect2>
 
24,5 → 25,9
<sect3><title>smath</title>
<para>Editeur de formules mathématiques.</para></sect3>
 
<sect3><title>spadmin</title>
<para>Configuration des imprimantes pour OpenOffice. Vous pourriez avoir
besoin de le lancer si vous avez des problèmes d'impression.</para></sect3>
 
</sect2>