Subversion Repositories svn LFS-FR

Compare Revisions

Regard whitespace Rev 7051 → Rev 7052

/trunk/blfs/general/genlib/libgsf.xml
77,8 → 77,7
make</userinput>
</screen>
<para>
Pour tester les résultats, tapez&nbsp;: <command>make -k check</command>. Certains tests
peuvent échouer pour des raisons inconnues.</para>
Pour tester les résultats, tapez&nbsp;: <command>make check</command>.</para>
<para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem>&nbsp;:</para>
<screen role="root">
<userinput>make install</userinput>
/trunk/blfs/general/prog/perl-modules.xml
129,12 → 129,22
<literallayout>&Archive-Zip-download-http;
Somme MD5: &Archive-Zip-md5sum;</literallayout>
<itemizedlist>
<listitem><literallayout><ulink url="http://search.cpan.org/~gfranks/Test-MockModule/">Test::MockModule</ulink>
(http://search.cpan.org/~gfranks/Test-MockModule/)</literallayout>
<listitem><literallayout><ulink url="http://search.cpan.org/dist/Test-MockModule/">Test::MockModule</ulink> - cela utilise <xref linken$
(http://search.cpan.org/dist/Test-MockModule/)</literallayout>
<itemizedlist>
<listitem> <literallayout><ulink url="http://search.cpan.org/dist/SUPER/">SUPER</ulink>
(http://search.cpan.org/dist/SUPER/) (pour la suite de tests)</literallayout>
<itemizedlist>
<listitem><literallayout><ulink url="http://search.cpan.org/dist/Sub-Identify/">Sub-Identify</ulink>
(http://search.cpan.org/dist/Sub-Identify/)(pour la suite de tests)</literallayout>
</listitem>
</itemizedlist>
</listitem>
</itemizedlist>
</listitem>
</itemizedlist>
</listitem>
</itemizedlist>
<bridgehead renderas="sect3" id="perl-autovivification"
xreflabel="autovivification-&autovivification-version;">
autovivification-&autovivification-version;</bridgehead>
587,7 → 597,16
<itemizedlist>
<listitem> <literallayout><ulink url="http://search.cpan.org/dist/CPAN-Meta-Check/">CPAN::Meta::Check</ulink>
(http://search.cpan.org/dist/CPAN::Meta::Check/) (pour la suite de tests)</literallayout>
<itemizedlist>
+<!-- FIXME : this duplicates the details for Test-Deep which is also needed by
+ Module-Metadata (below) : that (not _this_ one) can probably go after a
+ reasonable length of time -->
<listitem> <literallayout><ulink url="http://search.cpan.org/dist/Test-Deep/">Test::Deep</ulink>
(http://search.cpan.org/dist/Test::Deep/) (pour la suite de tests)</literallayout>
</listitem>
</itemizedlist>
 
</listitem>
<listitem> <literallayout><ulink url="http://search.cpan.org/dist/Module-Metadata/">Module::Metadata</ulink>
(http://search.cpan.org/dist/Module::Metadata/) (pour la suite de tests)
C'est un module du coeur de perl mais Test::Warnings demande au moins la version 1.000023
/trunk/blfs/networking/netlibs/libsoup.xml
91,6 → 91,13
<title>Explication des commandes</title>
<xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
href="../../xincludes/static-libraries.xml"/>
<para>
<option>--disable-vala</option>: utiliez si vous n'avez pas installé
Vala, car vous n'avez pas construit gnome.
</para>
 
 
 
<xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
href="../../xincludes/gtk-doc-rebuild.xml"/>
</sect2>
/trunk/blfs/postlfs/config/firmware.xml
Cannot display: file marked as a binary type.
svn:mime-type = application/xml
/trunk/blfs/postlfs/security/libpwquality.xml
63,6 → 63,11
</listitem>
</itemizedlist>
<bridgehead renderas="sect3">Dépendances de libpwquality</bridgehead>
<bridgehead renderas="sect4">Requises</bridgehead>
<para role="required">
<xref linkend="cracklib"/>
</para>
 
<bridgehead renderas="sect4">Recommandées</bridgehead>
<para role="recommended">
<xref linkend="linux-pam"/> et
/trunk/blfs/pst/typesetting/asymptote.xml
Cannot display: file marked as a binary type.
svn:mime-type = application/xml
/trunk/blfs/traduc/commits/r16919.txt
File deleted
/trunk/blfs/traduc/commits/r16920.txt
File deleted
/trunk/blfs/traduc/commits/r16921.txt
File deleted
/trunk/blfs/traduc/commits/r16922.txt
File deleted
/trunk/blfs/traduc/commits/r16923.txt
File deleted
/trunk/blfs/traduc/commits/r16924.txt
File deleted
/trunk/blfs/traduc/commits/r16925.txt
File deleted
/trunk/blfs/traduc/commits/r16926.txt
File deleted
/trunk/blfs/traduc/commits/r16927.txt
File deleted
/trunk/blfs/traduc/commits/r16928.txt
File deleted
/trunk/blfs/traduc/commits/r16929.txt
File deleted
/trunk/blfs/traduc/commits/r16939.txt
File deleted
/trunk/blfs/traduc/commits/r16938.txt
File deleted
/trunk/blfs/traduc/commits/r16937.txt
File deleted
/trunk/blfs/traduc/commits/r16936.txt
File deleted
/trunk/blfs/traduc/commits/r16935.txt
File deleted
/trunk/blfs/traduc/commits/r16930.txt
File deleted
/trunk/blfs/traduc/commits/r16931.txt
File deleted
/trunk/blfs/traduc/commits/r16932.txt
File deleted
/trunk/blfs/traduc/commits/r16933.txt
File deleted
/trunk/blfs/traduc/commits/r16934.txt
File deleted
/trunk/blfs/traduc/commits/r16945.txt
File deleted
/trunk/blfs/traduc/commits/r16944.txt
File deleted
/trunk/blfs/traduc/commits/r16943.txt
File deleted
/trunk/blfs/traduc/commits/r16942.txt
File deleted
/trunk/blfs/traduc/commits/r16941.txt
File deleted
/trunk/blfs/traduc/commits/r16940.txt
File deleted
/trunk/blfs/x/installing/xorg-server.xml
68,6 → 68,13
<ulink url="&patch-root;/xorg-server-&xorg-server-version;-add_prime_support-1.patch"/>
</para>
</listitem>
<listitem>
<para>
Correctif recommandé (requis par <xref linkend="wayland"/>):
<ulink url="&patch-root;/xorg-server-&xorg-server-version;-wayland_190-1.patch"/>
</para>
</listitem>
 
</itemizedlist>
<bridgehead renderas="sect3">Dépendances de Xorg Server</bridgehead>
<bridgehead renderas="sect4">Requises</bridgehead>
106,6 → 113,11
<screen>
<userinput>patch -Np1 -i ../xorg-server-&xorg-server-version;-add_prime_support-1.patch</userinput>
</screen>
<para>
Si vous avez téléchargé le correctif recommandé, appliquez le en lançant la commande suivante:
</para>
<screen><userinput>patch -Np1 -i ../xorg-server-&xorg-server-version;-wayland_190-1.patch</userinput></screen>
 
<para>Installez le serveur en lançant les commandes suivantes&nbsp;:</para>
<screen>
<userinput>./configure $XORG_CONFIG --enable-glamor --enable-install-setuid --enable-suid-wrapper --disable-systemd-logind --with-xkb-output=/var/lib/xkb &amp;&amp;
165,9 → 177,10
<segtitle>Répertoires installés</segtitle>
<seglistitem>
<seg>
cvt, dmxaddinput, dmxaddscreen, dmxinfo, dmxreconfig, dmxresize,
dmxrminput, dmxrmscreen, dmxtodmx, dmxwininfo, gtf, vdltodmx, X,
Xdmx, xdmxconfig, Xephyr, Xnest, Xorg, et Xvfb
cvt, gtf, X, Xnest, Xorg, et Xvfb; facultativement: dmxaddinput,
dmxaddscreen, dmxinfo, dmxreconfig, dmxresize, dmxrminput,
dmxrmscreen, dmxtodmx, dmxwininfo, vdltodmx, Xdmx, xdmxconfig, Xephyr,
et Xfbdev
</seg>
<seg>
plusieurs sous $XORG_PREFIX/lib/xorg/modules/{,drivers,extensions} en incluant modesetting_drv.so
/trunk/blfs/xsoft/graphweb/firefox.xml
114,7 → 114,7
<xref linkend="valgrind"/>,
<xref linkend="wget"/>
<xref linkend="wireless_tools"/>
<ulink url="http://hunspell.sourceforge.net/">Hunspell</ulink>,
<ulink url="https://hunspell.github.io/">Hunspell</ulink>,
<ulink url="http://sourceforge.net/projects/liboauth/files/">liboauth</ulink>
<ulink url="https://github.com/libproxy/libproxy">libproxy</ulink> et
<ulink url="https://www.rust-lang.org/">Rust</ulink>
/trunk/blfs/xsoft/office/gnumeric.xml
90,7 → 90,11
<userinput>make install</userinput>
</screen>
<para>
Si vous souhaitez tester les résultats, tapez <command>make -k check</command>.
Si vous souhaitez tester les résultats, commencez par désactiver trois tests qui échouent;
<screen><userinput>sed \
-e '/\tt6500-strings.*/d;/\tt6506-cell-comments.*/d;/\tt6509-validation.*/d' \
-i test/Makefile</userinput></screen>
ensuite tapez <command>make check</command>.
Les tests doivent être lancés dans une session X active, et <xref linkend="dconf"/>
doit être installé pour prévenir des échecs. Cependant quelques tests échouent pour des raisons
inconnues.
/trunk/blfs/xsoft/office/libreoffice.xml
125,12 → 125,6
Taille du téléchargement des traductions: &libreoffice-translations-size;
</para>
</listitem>
<listitem>
<para>
correctif requis pour utiliser <xref linkend="boost"/>:
<ulink url="&patch-root;/libreoffice-&libreoffice-dlversion;-boost_1_60_0-1.patch"/>
</para>
</listitem>
 
</itemizedlist>
<bridgehead renderas="sect3">Dépendances de Libre Office</bridgehead>
147,9 → 141,10
<para>
La plupart de ces paquets sont recommandés car s'ils ne sont pas installés, le
processus de construction compilera et installera sa propre version
(souvent ancienne).</para>
(souvent ancienne), avec l'effet de bord d'augmenter l'espace disque de contruction et d'installation, ainsi que le temps de construction.</para>
</note>
<para role="recommended">
<xref linkend="apr"/>,
<xref linkend="boost"/>,
<xref linkend="clucene"/>,
<xref linkend="cups"/>,
162,6 → 157,7
<xref linkend="gtk2"/>,
<xref linkend="harfbuzz"/>,
<xref linkend="icu"/>,
<xref linkend="libatomic_ops"/>,
<xref linkend="lcms2"/>,
<xref linkend="librsvg"/>,
<xref linkend="libxml2"/> et <xref linkend="libxslt"/>,
172,8 → 168,10
<xref linkend="openldap"/> (si connecté à un serveur LDAP),
<xref linkend="openssl"/> ou <xref linkend="gnutls"/>,
<xref linkend="poppler"/>,
<xref linkend="postgresql"/>,
<xref linkend="python3"/> (utilisé pour construire les traductions),
<xref linkend="redland"/> et
<xref linkend="redland"/>,
<xref linkend="serf"/>, et
<xref linkend="unixodbc"/>
</para>
<bridgehead renderas="sect4">Facultatives</bridgehead>
181,18 → 179,16
<xref linkend="apache-ant"/>,
<xref linkend="avahi"/>,
<xref linkend="bluez"/>,
<xref linkend="dconf"/>,
<xref linkend="desktop-file-utils"/>,
<xref linkend="doxygen"/> (pas utile si utilisation de --disable-odk),
<xref linkend="GConf"/>,
<xref linkend="gdb"/>,
<xref linkend="gtk3"/> (voir <quote>Explications des commandes</quote>),
<xref linkend="kdelibs"/>,
<xref linkend="libatomic_ops"/>,
<xref linkend="mariadb"/> ou <ulink url="http://www.mysql.com/">MySQL</ulink>,
<xref linkend="mitkrb"/>,
<xref linkend="nasm"/>,
<xref linkend="openjdk"/>,
<xref linkend="postgresql"/>,
<xref linkend="sane"/>,
<xref linkend="valgrind"/>,
<xref linkend="vlc"/>,
205,11 → 201,12
<ulink url="http://sourceforge.net/projects/cppunit/">Cppunit</ulink>,
<ulink url="http://www.firebirdsql.org/">firebird</ulink>,
<ulink url="http://downloads.sourceforge.net/glew/">glew (bibliothèque OpenGL Extension Wrangler)</ulink>,
<ulink url="https://github.com/behdad/glyphy">glyphy</ulink>,
<ulink url="http://ftp.gnome.org/pub/gnome/sources/gnome-vfs/">Gnome VFS</ulink>,
<ulink url="https://code.google.com/p/hamcrest/">hamcrest</ulink>,
<ulink url="http://hunspell.sourceforge.net/">Hunspell</ulink>,
<ulink url="https://github.com/hamcrest/JavaHamcrest/releases">hamcrest</ulink>,
<ulink url="https://hunspell.github.io/">Hunspell</ulink>,
<ulink url="http://sourceforge.net/projects/hunspell/files/Hyphen/">Hyphen</ulink>,
<ulink url="https://code.google.com/p/include-what-you-use/">iwyu</ulink>,
<ulink url="http://include-what-you-use.org/">iwyu</ulink>,
<ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libabw">libabw</ulink>,
<ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libcdr">libcdr</ulink>,
<ulink url="http://sourceforge.net/projects/libcmis/">libcmis</ulink>,
227,7 → 224,7
<ulink url="http://libwpg.sourceforge.net/">libwpg</ulink>,
<ulink url="http://libwps.sourceforge.net/">libwps</ulink>,
<ulink url="http://lpsolve.sourceforge.net/">lp_solve</ulink>,
<ulink url="http://code.google.com/p/multidimalgorithm/">mdds</ulink>,
<ulink url="https://gitlab.com/mdds/mdds">mdds</ulink>,
<ulink url="http://sourceforge.net/projects/hunspell/files/MyThes/">MyThes</ulink>,
<ulink url="http://sourceforge.net/projects/ogl-math/">ogl-math - OpenGL Mathematics (GLM)</ulink>,
<ulink url="https://github.com/KhronosGroup/OpenCOLLADA/">OpenCOLLADA</ulink>,
412,6 → 409,20
au lieu de celui en interne.
</para>
<para>
<parameter>--with-system-boost=<replaceable>&lt;yes/no&gt;</replaceable></parameter>:
Ce paramètre active/désactive l'utilisation de la version boost du système, donc la verion empaqueté peut être ou pas
utilisée, car actuellement, en fonction de la décision de l'utilisateur, ou si la construction est cassée avec la
dernière version de <application>Boost</application> dans BLFS, qui apparait souvent et il y a un délai jusqu'à ce qu'un correctif
soit trouvé ou que ce soit corrigé par les développpeurs.
</para>
 
<para>
<parameter>--disable-dconf</parameter>: Ce paramètre désactive la compilation de
<application>LibreOffice</application> avec le système de configuration système
<application>GNOME DConf</application>.
</para>
 
<para>
<parameter>--without-system-dicts</parameter>: Ce paramètre désactive l'utilisation
des dicitionnaires depuis les chemins système, donc les seuls installés par ce paquet
sont utilisés.
422,23 → 433,11
<application>Java</application>.
</para>
<para>
<parameter>--disable-gconf</parameter>&nbsp;: Enlevez cette option si vous voulez
compiler <application>LibreOffice</application> avec le support de configuration
obsolète de <application>GNOME</application>.</para>
<para>
<parameter>--disable-odk</parameter>&nbsp;: Ceci désactive l'installation du kit
de développement de bureautique. Supprimez cette option si vous voulez
développer une application basée sur <application>Libre Office</application>.
</para>
<para>
<parameter>--disable-postgresql-sdbc</parameter>&nbsp;: Cette option désactive la compilation
de <application>LibreOffice</application> avec la capacité de se connecter à une base de données <application>PostgreSQL</application>. Si vous
souhaitez que <application>LibreOffice</application> soit capable de se connecter à une base de données <application>PostgreSQL</application>
supprimez cette option. Si vous avez installé <application>PostgreSQL</application> sur votre système et
que vous souhaitez que <application>LibreOffice</application> l'utilise plutôt que sa propre version, ajoutez
l'option <option>--with-system-postgresql</option>.
</para>
<para>
<parameter>--enable-release-build=yes</parameter>: Ce paramètre active Release Build.
<application>LibreOffice</application> peut être construit en Release Build ou
en Developer Build, car leur chemin d'installation par défaut et les chemins de profile utilisateur
475,6 → 474,14
<xref linkend="gst10-plugins-base"/>.
</para>
<para>
<parameter>--disable-postgresql-sdbc</parameter>&nbsp;: Cette option désactive la compilation
de <application>LibreOffice</application> avec la capacité de se connecter à une base de données <application>PostgreSQL</application>. Si vous
souhaitez que <application>LibreOffice</application> soit capable de se connecter à une base de données <application>PostgreSQL</application>
supprimez cette option. Si vous avez installé <application>PostgreSQL</application> sur votre système et
que vous souhaitez que <application>LibreOffice</application> l'utilise plutôt que sa propre version, ajoutez
l'option <option>--with-system-postgresql</option>.
</para>
<para>
<option>--enable-gtk3</option>: Utilisez ce paramètre si vous voulez construire le module
d'intégration
<application>GTK+ 3</application>.
/trunk/blfs/xsoft/other/fontforge.xml
Cannot display: file marked as a binary type.
svn:mime-type = application/xml